HDU 5916 Harmonic Value Description (水题)

Harmonic Value Description

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 150    Accepted Submission(s): 105
Special Judge

Problem Description
The harmonic value of the permutation p1,p2,pn is
i=1n1gcd(pi.pi+1)

Mr. Frog is wondering about the permutation whose harmonic value is the strictly k-th smallest among all the permutations of [n].
 

Input
The first line contains only one integer T ( 1T100 ), which indicates the number of test cases.

For each test case, there is only one line describing the given integers n and k ( 12kn10000 ).
 

Output
For each test case, output one line “Case #x: p1 p2  pn ”, where x is the case number (starting from 1) and p1 p2  pn is the answer.
 

Sample Input
  
  
2 4 1 4 2
 

Sample Output
  
  
Case #1: 4 1 3 2 Case #2: 2 4 1 3
 

Source

题意:给出数字n,对于全排列序列1-n,其harmonic value定义为序列中相邻两个数的最大公约数之和,构造一个和大小为所有全排列序列harmonic value中第k大的harmonic value的序列。
思路:一开始打表想找规律,发现harmonic value是从n-1开始的连续数字,且1-n的数字排序的harmonic value即为n-1,因为相邻两个数字的最大公约数为1,因此第k大的harmonic value即为和为n-1+k-1的序列。对于k=1直接输出1-n即可,对于k为偶数情况,可以直接把k和2k提到1之前,即可贡献k,又因为k和2k都为偶数,所以这两个数字的移动不会造成序列中其他相邻最大公约数的改变。对于k为奇数的情况,可以把从3开始的奇数位提前,这样剩下的相邻偶数可贡献2,即在原来的n-1基础上+1。

#include <iostream>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <map>
using namespace std;

int main(){
	
	int t;
	scanf("%d",&t);
	for(int cas=1;cas<=t;cas++){
		map<int,int> m;
		int n,k;
		scanf("%d %d",&n,&k);
		printf("Case #%d: ",cas);
		if(k==1){
			for(int i=1;i<=n-1;i++)
				printf("%d ",i);
			printf("%d\n",n);
		}
		else{
			if(k%2==0){ 
				printf("%d %d",k,2*k);
			for(int i=1;i<=n;i++){
				if(i==k||i==2*k)
					continue;
				else
					printf(" %d",i);
				}
			printf("\n");
			}
		else{
			printf("%d",3);
			m[3]=1;
			for(int i=2;i<k;i++){
				printf(" %d",2*i+1);
				m[2*i+1]=1;
			}
			for(int i=1;i<=n;i++){
				if(m[i]==1)
					continue;
				else
					printf(" %d",i);
				}
				printf("\n");
			}
		}
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值