ZOJ - 3872

ZOJ - 3872 Beauty of Array

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input
There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output
For each case, print the answer in one line.

Sample Input
3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2
Sample Output
105
21
38

其实没想到是dp……我自己的思路是优化循环,通过标记把重复的去掉,但是看数据还是很有可能超时。后来……后来队友就把题做出来了,就没再想。

反转,从后往前推,其实不用那个反转也行,就是麻烦点,如果数据不重复的话其实就是个全排列dp[i]=i*a[i]+dp[i-1];然后刨去重复的,就是乘的时候减去之前出现的最后一次下标,就出来了呀~

#include<cstdio>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstring>
#include <cctype>
#include <stack>
#include <queue>
#define N 100050
#define mod 1000000007
using namespace std;
typedef long long ll;
const int INF=0x3f3f3f3f;
int book[N*10],a[N];
long long dp[N];
int main(){
	int t,n,i;
	long long sum;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		sum=0;
		memset(dp,0,sizeof(dp));
		memset(book,0,sizeof(book));
		for(i=1;i<=n;i++){
			scanf("%d",&a[i]);
		}
		reverse(a+1,a+1+n);
		for(i=1;i<=n;i++){
			dp[i]=(i-book[a[i]])*a[i]+dp[i-1];
			book[a[i]]=i;
		}
		for(i=1;i<=n;i++){
			sum+=dp[i];
		}
		printf("%lld\n",sum);
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值