Beauty of Array ZOJ - 3872

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input
There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output
For each case, print the answer in one line.

Sample Input
3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2
Sample Output
105
21
38
这道题刚开始想的是用多个for循环,但是仔细看了一下,发现给的数据太大了,如果用多个for循环一定会时间超限。。。。
然后用动态规划。对于2 3 3 这组数据来说,如果倒过来看,3, 有{3}这一个子数组,这组数的和是3。然后是3,有{3}, {3,3}两个子数组。它的和是(2 - 1)* 3 + 3 = 6。最后是2,有{2},{2,3},{2,3,3},它的和是 (3 - 0)* 2 + 6 = 12。所以全部的和是21。
这里可以推断出dp[i] = (i - book[a[i]]) * a[i] + dp[i-1]。
里边的book用来寻找a[i]的重复数。详细的看代码体会。。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define max 100050
using namespace std;
int book[max * 10], a[max];
long long dp[max];
int main()
{
    int T;
    scanf ("%d", &T);
    while (T --)
    {
        int m;
        scanf ("%d", &m);
        memset(dp, 0, sizeof(dp));
        memset(book, 0, sizeof(book));
        for (int i = 1; i <= m; i ++)
            scanf ("%d", &a[i]);
        reverse (a + 1, a + 1 + m);//这里是反转数组。
        for (int i = 1; i <= m; i ++)
        {
            dp[i] = (i - book[a[i]]) * a[i] + dp[i-1]; 
            book[a[i]] = i;
        }
        long long sum = 0;
        for (int i = 1; i <= m; i ++)
        {
            sum += dp[i];
        } 
        printf("%lld\n", sum);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值