ZOJ 3872 Beauty of Array(DP)

ZOJ 3872 Beauty of Array

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input
There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:
The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.
Output
For each case, print the answer in one line.
Sample Input
3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2
Sample Output
105
21
38

据说是浙江省赛的银牌题,我一开始还不会做…TAT

题意:计算一串数字序列的所有连续子串的数字之和(重复出现的数字只计算一次),累加并输出。

肯定不能暴力,所以我们自然而然想到,在末尾加入一个数字后的数字序列的输出值可以通过某种方法由上一个序列的输出值获得。

例如有序列1,2,3,4,5

若在末尾加入一个序列中没有的数N,则新产生的子序列为:

N;

5,N;

4,5,N;

3,4,5,N;

2,3,4,5,N;

1,2,3,4,5,N;

则增加的输出值为:

5;

4,5;

3,4,5;

2,3,4,5;

1,2,3,4,5;

的输出值+6*N;

若在末尾加入一个序列中出现过的数字3,则新产生的子序列为:

3;

5,3;

4,5,3;

3,4,5,3;

2,3,4,5,3;

1,2,3,4,5,3;

其中,最后三个子序列,因为末尾的3是第二次出现,故输出值里不将其计入,因此有效的子序列只有前面3个;

其增加的输出值为:

5;

4,5;

的输出值+(6-3)*3;


归纳为:

1)当末尾数字在前面序列中未出现过时,add+=i*k,sum+=add;

2)当末尾数字在前面第j个位置出现过时,add+=(i-j)*k,sum+=add;

i为当前处理数字的位置,k为其值。

add,sum初始化为0。

设置一个last数组保存每个数字当前最后出现的位置,并初始化为-1。


因为以为数字序列中每个数字都是个位数而wa了若干发。

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#define maxn 100005
using namespace std;
int input[maxn];
long long sum;
int last[1000005];
int main(){
    int T,N,k,i;
    long long add;
    scanf("%d",&T);
    while(T--){
        memset(last,-1,sizeof(last));
        scanf("%d",&N);
        for(i=1;i<=N;i++){
            scanf("%d",&input[i]);
        }
        sum=input[1];
        add=input[1];
        last[input[1]]=1;
        for(i=2;i<=N;i++){
            k=input[i];
            if(last[k]==-1){//该数字第一次出现
                add+=i*k;
            }
            else{//该数字出现过
                add+=(i-last[k])*k;
            }
            sum+=add;
            last[k]=i;
        }
        cout<<sum<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值