给定一个模式串S,以及一个模板串P,所有字符串中只包含大小写英文字母以及阿拉伯数字。
模板串P在模式串S中多次作为子串出现。
求出模板串P在模式串S中所有出现的位置的起始下标。
输入格式
第一行输入整数N,表示字符串P的长度。
第二行输入字符串P。
第三行输入整数M,表示字符串S的长度。
第四行输入字符串M。
输出格式
共一行,输出所有出现位置的起始下标(下标从0开始计数),整数之间用空格隔开。
数据范围
1≤N≤104
1≤M≤105
输入样例:
3
aba
5
ababa
输出样例:
0 2
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int N = 1e4+10;
const int M = 1e5+10;
int n,m;
char p[N],s[N];
int ne[N];
int main()
{
cin>>n>>p+1>>m>>s+1;
//求next数组过程(最长前后缀)
for (int i=2,j=0;i<=n;i++)
{
while (j && p[i]!=p[j+1])
{
j=ne[j];
}
if (p[i]==p[j+1])
{
j++;
}
ne[i]=j;
}
//kmp匹配过程
for (int i=1,j=0;i<=m;i++)
{
while (j && s[i]!=p[j+1])
{
j=ne[j];
}
if (s[i]==p[j+1])
{
j++;
}
if (j==n)
{
printf("%d ",i-n);
j=ne[j];//一个模式串可能有多个模板串
}
}
return 0;
}