1005. Spell It Right

Spell It Right

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 1 0 100 10^{100} 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

题意

给定一个数,计算各位数之和,并将和的每一位用英文输出。

思路

题目较简单,按步骤操作即可。为了方便起见使用STL模版。


代码实现

#include <iostream>
#include <map>
#include <string>
using namespace std;

map<int, string> en;

void createEn()     // 创建map映射表
{
	en[0] = "zero";
	en[1] = "one";
	en[2] = "two";
	en[3] = "three";
	en[4] = "four";
	en[5] = "five";
	en[6] = "six";
	en[7] = "seven";
	en[8] = "eight";
	en[9] = "nine";
}


int sum(string n)   // 计算各位数之和
{
	int ans = 0;
	for (int i = 0; i < n.length(); i++)
		ans += n[i] - '0';
	 return ans;
}

void printEnglish(int n, bool &flag)    // 递归输出结果,flag用于控制空格输出
{
	if (n == 0)
		return;
	printEnglish(n / 10, flag);
	if (flag)
	{
		cout << en[n % 10];
		flag = false;
	}
	else
		cout << " " << en[n % 10];
}

int main()
{
	createEn();
	bool flag = true;       // 控制空格输出
	string n;
	cin >> n;
	if (sum(n) == 0)
		cout << en[0];
	else
		printEnglish(sum(n), flag);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值