hdu1690(最短路floyd)

202 篇文章 0 订阅
123 篇文章 0 订阅

Problem Description
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.



Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.
 

Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.
 

Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.
 

Sample Input
  
  
2 1 2 3 4 1 3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4
 

Sample Output
  
  
Case 1: The minimum cost between station 1 and station 4 is 3. The minimum cost between station 4 and station 1 is 3. Case 2: Station 1 and station 4 are not attainable.

         题目意思读懂了就好做了,题意前面输入的那8个数我们都应该懂吧,然后输入n,m,n表示n个地点,然后输入n个数,每个数表示第i个地点在数轴上的横坐标,然后输入m次询问操作,输出结果。这题本来刚开始想去spfa的,结果到后来想着每组询问都要一次spfa不划算那就算了,而floyd一次算完了直接取值就行,所以用了floyd。不过这题题目数据卡的很大,网上很多人说貌似大到了10的18次方,所以直接用-1代替。同时刚开始我用int结果wa了,仔细读题发现虽然输入的数据最大int可以存下,可是算最短路算的是人家的和啊,所以,很多和加在一起确实是可能爆int,所以规规矩矩longlong 吧,而且刚开始我只是把输出里面的

 printf("The minimum cost between station %d and station %d is %lld.\n",a,b,cc[a-1][b-1]);
写成了
 printf("The minimum cost between station %d and station %d is %d.\n",a,b,cc[a-1][b-1]);
都赤裸裸的wa,涨姿势了。。。。。。

#include <iostream>
#include<math.h>
#include <cstdio>
#include <cstring>
#include<algorithm>
#define max0 999999
using namespace std;
typedef long long ll;
ll a[110],cc[110][110];
int main()
{
    int t,o=1;
    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));
        memset(cc,0,sizeof(cc));
        ll  L1,L2,L3,L4, C1, C2, C3, C4;
        scanf("%lld%lld%lld%lld%lld%lld%lld%lld\n",& L1, &L2,& L3,& L4,& C1,& C2,& C3,& C4);
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
        {
            scanf("%lld",&a[i]);
            for(int j=0;j<=i;j++)
            {
                int t=abs(a[j]-a[i]);
                if(t==0)
                    cc[i][j]=0;
                else if(t>0&&t<=L1)
                    cc[i][j]=cc[j][i]=C1;
                else if(t>L1&&t<=L2)
                    cc[i][j]=cc[j][i]=C2;
                else if(t>L2&&t<=L3)
                    cc[i][j]=cc[j][i]=C3;
                else if(t>L3&&t<=L4)
                    cc[i][j]=cc[j][i]=C4;
                else cc[i][j]=cc[j][i]=-1;
            }
        }
       /* for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
                cout<<cc[i][j]<<' ';cout<<endl;
        }*/
        for(int k=0;k<n;k++)
            for(int i=0;i<n;i++)
                for(int j=0;j<n;j++)
        {
            if(cc[i][k]!=-1&&cc[k][j]!=-1)
            {
                if(cc[i][j]>cc[i][k]+cc[k][j]||cc[i][j]==-1)
                cc[i][j]=cc[i][k]+cc[k][j];
            }
        }
       /* cout<<endl;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
                cout<<cc[i][j]<<' ';cout<<endl;
        }*/
        printf("Case %d:\n",o++);
        for(int i=0;i<m;i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            if(cc[a-1][b-1]!=-1)
            printf("The minimum cost between station %d and station %d is %lld.\n",a,b,cc[a-1][b-1]);
            else printf("Station %d and station %d are not attainable.\n",a,b);
        }
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值