题目描述 Description
有这样的一个集合,集合中的元素个数由给定的N决定,集合的元素为N个不同的正整数,一旦集合中的两个数x,y满足y = P*x,那么就认为x,y这两个数是互斥的,现在想知道给定的一个集合的最大子集满足两两之间不互斥。
输入描述 Input Description
输入有多组数据,每组第一行给定两个数N和P(1<=N<=10^5, 1<=P<=10^9)。接下来一行包含N个不同正整数ai(1<=ai<=10^9)。
输出描述 Output Description
输出一行表示最大的满足要求的子集的元素个数。
样例输入 Sample Input
4 2
1 2 3 4
样例输出 Sample Output
3
题解:将所有数从小到大排序。对于x和p*x,删去p*x一定最优,因为x和p*x*x都可以合法
#include<iostream>
#include<algorithm>
#include<map>
using namespace std;
const int maxn=100010;
int n,m,ans,a[maxn];
map<int,int> hash;
int main()
{
cin>>n>>m;
for(int i=1;i<=n;i++)
cin>>a[i];
sort(a+1,a+n+1);
for(int i=1;i<=n;i++)
if(!hash[a[i]])
{
hash[a[i]*m]=1;
ans++;
}
cout<<ans;
return 0;
}