解题报告 之 HDU5326 Work

18 篇文章 0 订阅
2 篇文章 0 订阅

解题报告 之 HDU5326 Work


Description



It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company. 
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B. 
Now, give you the relation of a company, can you calculate how many people manage k people. 
 

Input

There are multiple test cases. 
Each test case begins with two integers n and k, n indicates the number of stuff of the company. 
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B. 

1 <= n <= 100 , 0 <= k < n 
1 <= A, B <= n 
 

Output

For each test case, output the answer as described above.
 

Sample Input

     
     
7 2 1 2 1 3 2 4 2 5 3 6 3 7
 

Sample Output

     
     
2

题目大意:一个公司,每个人(除了老板)都有一个直接上司,上司的上司还是你的间接上司。给你一个关系树的每条边,问你树中有多少个节点的子孙数为k?(直接下属+间接下属)。

分析:可以看到数据规模很小,那么就是一道深度搜索的水题,可以算是图论很大众的知识了。结点的下属数 = 直接下属数 + 每个下属的下属数。那么就是一个递归了。

上代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<cstring>
using namespace std;

const int MAXN = 1e2+10;

vector<int> node[MAXN];
int deg[MAXN];
int ma[MAXN];

int dfs(int u)
{
	if(node[u].size() == 0)
	{
		ma[u] = 0;
		return ma[u] + 1;
	}

	for(int i = 0; i < node[u].size(); i++)
		ma[u] += dfs( node[u][i] );

	return ma[u] + 1;
}

int main()
{
	int n, k;
	while(scanf( "%d%d", &n, &k ) == 2)
	{
		for(int i = 0; i < MAXN; i++)
			node[i].clear();
		memset( deg, 0, sizeof deg );
		memset( ma, 0, sizeof ma );

		int a, b,root;
		for(int i = 0; i <n-1; i++)
		{
			scanf( "%d%d", &a, &b );
			node[a].push_back( b );
			deg[b]++;
		}

		for(int i = 1; i <= n; i++)
		{
			if(deg[i] == 0)
			{
				root = i;
				break;
			}
		}
		dfs( 1 );
		int ans = 0;
		for(int i = 1; i <= n; i++)
		{
			if(ma[i] == k)
				ans++;
		}
		printf( "%d\n", ans );
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值