解题报告 之 HDU 4405 Aeroplane chess

6 篇文章 0 订阅

解题报告 之 HDU 4405 Aeroplane chess


Description

Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N. 

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid. 

Please help Hzz calculate the expected dice throwing times to finish the game. 
 

Input

There are multiple test cases. 
Each test case contains several lines. 
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000). 
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).   
The input end with N=0, M=0. 
 

Output

For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point. 
 

Sample Input

     
     
2 0 8 3 2 4 4 5 7 8 0 0
 

Sample Output

     
     
1.1667 2.3441
 

Source

2012 ACM/ICPC Asia Regional Jinhua Online

题目大意:下飞行棋,你从0开始投掷一枚均匀的骰子(1~6)。投中哪个数就走几步,直到走到大于等于n则游戏结束。地图上还有m条航线可以直接把你带到更远的地方。一旦走到航线起点,则立即飞往航线终点且不用投掷骰子,如果航线1的终点是航线2的起点则连续飞两次。不存在两条航线起点相同。问游戏结束所需要的步数期望。

分析:一道大水概率DP,状态转移方程非常好想。对于某个点u,如果它是某航线的起点,那么它的期望就直接等于该航线终点v的步数期望,即dp[ui]=dp[vi]。因为此时 u 只能转移到 v 。如果点u不是航线起点,那么它就等可能的转移到i+1,+2,+3,+4,+5,+6。那么dp[i]=∑1.0/6.0*dp[i+j],j=1,2,3,4,5,6。

最后就是注意要清零数组。

上代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

const int MAXN = 1e5 + 10;
int line[MAXN];
double dp[MAXN];


int main()
{
	int n, m;
	while(scanf( "%d%d", &n, &m ) == 2)
	{
		if(n == 0 && m == 0) break;
		memset( line, -1, sizeof line );
		memset( dp, 0, sizeof dp );
		int u, v;
		for(int i = 1; i <= m; i++)
		{
			scanf( "%d%d", &u, &v );
			line[u] = v;
		}
		for(int i = n-1; i >= 0; i--)
		{
			if(line[i] != -1)
			{
				dp[i] = dp[line[i]];
			}
			else
			{
				for(int j = 1; j <= 6; j++)
				{
					dp[i] += dp[i + j];
				}
				dp[i] /= 6.0;
				dp[i] += 1.0;
			}
		}
		printf( "%.4lf\n", dp[0] );
	}

	return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值