FatMouse' Trade

FatMouse' Trade

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 11   Accepted Submission(s) : 4
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500
这个题目是暑假写过很多次的,有一些小的细节没有想清楚,导致出错。
1.忘了double和float的printf输出形式。
2.存在老鼠带的猫粮过多,走完所有房间也不能将猫粮全部兑换完的情况,所以应该用房间个数做循环,而不是老鼠所带猫粮的多少来做循环。
大致就是这两个小点,还是自己的思维不够细致,长时间不刷题导致的,
下面是AC代码:
#include<iostream>
#include<stdio.h>
#include<algorithm> 
using namespace std;
struct r{
	double f,j,a;
}room[1000]; 
bool cmp(r &b,r &c){
	return b.a>c.a;
}
int main(){
	int m,n;
	while(cin>>m>>n){
		if(m==-1&&n==-1){
			break;
		}
		for(int i=0;i<n;i++){
			cin>>room[i].j>>room[i].f;
			room[i].a=room[i].j/room[i].f;
		}
		sort(room,room+n,cmp);
		double sum=0;
		int i=0;
		for(int i=0;i<n;i++){
		 if (m>room[i].f)  
            {  
                sum+=room[i].j;  
                m-=room[i].f;  
            } 
            else  
            {  
                sum+=m*room[i].j/room[i].f;  
                break;  
            }
		}
		printf("%.3lf\n",sum);
	}
	return 0;
}


>煤球酱

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值