HDU 1236 结构体排序

http://acm.split.hdu.edu.cn/showproblem.php?pid=1236


排名

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 21191    Accepted Submission(s): 7878


Problem Description
今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑 
每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的 
考生,并将他们的成绩按降序打印。 
 

Input
测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N 
< 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一 
名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号 
(题目号由1到M)。 
当读入的考生人数为0时,输入结束,该场考试不予处理。 
 

Output
对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高 
到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考 
号的升序输出。 
 

Sample Input
  
  
4 5 25 10 10 12 13 15 CS004 3 5 1 3 CS003 5 2 4 1 3 5 CS002 2 1 2 CS001 3 2 3 5 1 2 40 10 30 CS001 1 2 2 3 20 10 10 10 CS000000000000000001 0 CS000000000000000002 2 1 2 0
 

Sample Output
  
  
3 CS003 60 CS001 37 CS004 37 0 1 CS000000000000000002 20
Hint
Huge input, scanf is recommended.




//hdu 1236
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>
using namespace std;
int n;//考生数
int m;//考题数
int g;//分数线
const int maxn=15;

struct student{
	char str[25];//准考证号
	int sum;//解决题目总数
	int grade;//这个考生的分数
}stu[1005];

bool cmp(const student &a,const student &b)
{
	if (a.grade==b.grade)
		return strcmp(a.str,b.str)<0?1:0;//按考号升序排列 
	return a.grade>b.grade;
}

int score[15];//m道题的分数
int ans=0;
int main()
{
	while (~scanf("%d",&n),n)
	{
		int i,j;
		ans=0;
		scanf("%d%d",&m,&g);
		for (i=1;i<=m;i++)//m道题的分数
			scanf("%d",&score[i]);
		for (i=0;i<n;i++)//n个考生的考号,题目数,题号
		{
			scanf("%s%d",stu[i].str,&stu[i].sum);
			stu[i].grade=0;
			for (j=0;j<stu[i].sum;j++)
			{
				int a;
				scanf("%d",&a);
				stu[i].grade+=score[a];
			}
			if (stu[i].grade>=g)
				ans++;
		}
		sort (stu,stu+n,cmp);
		printf ("%d\n",ans);
		for (i=0;i<ans;i++)
			printf("%s %d\n",stu[i].str,stu[i].grade);
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值