hdu 3823 素数打表+vector可变长数组 好烦的一道好题。。。。。



http://acm.hdu.edu.cn/showproblem.php?pid=3823


Prime Friend

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2855    Accepted Submission(s): 580


Problem Description
Besides the ordinary Boy Friend and Girl Friend, here we define a more academic kind of friend: Prime Friend. We call a nonnegative integer A is the integer B’s Prime Friend when the sum of A and B is a prime.
So an integer has many prime friends, for example, 1 has infinite prime friends: 1, 2, 4, 6, 10 and so on. This problem is very simple, given two integers A and B, find the minimum common prime friend which will make them not only become primes but also prime neighbor. We say C and D is prime neighbor only when both of them are primes and integer(s) between them is/are not.
 

Input
The first line contains a single integer T, indicating the number of test cases.
Each test case only contains two integers A and B.

Technical Specification

1. 1 <= T <= 1000
2. 1 <= A, B <= 150
 

Output
For each test case, output the case number first, then the minimum common prime friend of A and B, if not such number exists, output -1.
 

Sample Input
  
  
2 2 4 3 6
 

Sample Output
  
  
Case 1: 1 Case 2: -1


题解


题意:  即求一个数,能使a,b与之相加后,成为素数,并且a与b之间没有其他的素数。


vector开变长数组

         初始化:vertor<int> a[100];               //即开的是二维数组,可以包含100行,每行的长度可以不同。
 
                     a[2].push_back(i);                    //将i放入第二行的尾部
 
                     a[2].size();                           //获得第二行的长度



心路历程:...

一开始写了一遍。。运行不了。。debug发现prime数组开小了

开大。。。提交。。。超内存...

max改成  ? :  。。降了一半

cin .cout改成scanf..  没变化。。

把isprime()拉到主函数里来。。。 没变化。

发现素数打表有一个地方写错。。。改正了。。没变化。。

把素数的数组改成bool(一开始用Int)。。。好了一点。。。

最后不用G++提交了。。。换了C++提交。。。然后就过了。。。。。。。好气哦。。。做了这么久的题





//hdu 3823
#include <iostream>
#include <cstring>
#include <cstdio>
#include <string>
#include <algorithm>
#include <vector>
using namespace std;
typedef long long ll;
//题意:给出两个数字a,b。使a + x, b + x都是素数,并且它们之间没有素数。求出这样的最小的x。
//http://www.cnblogs.com/yumao1006/archive/2012/08/30/2664591.html
/*
暴力打表,找出20000000以内的素数,求出相邻素数的差,存放在vector的数组中
*/


//学习::把max函数换成?:能省一半内存。。。。
//学习::把cin cout 换成scanf,能省一半时间。。。
//一开始,素数打表那里条件写成i < maxn 。。。错了好多次啊。。
const int maxn = 20000000 + 5;//在这里面素数的差才可能在150以内
bool pp[maxn];//筛选法找素数
int prime[maxn/2];//存放素数
vector <int>vec[155];
void isprime()
{
	memset(pp, 0, sizeof(pp));
	pp[1] = 1;
	for (int i = 2; i*i < maxn; i++)
	{
		if (!pp[i]) //0是素数
		{
			for (int j = i + i; j < maxn; j+=i)
			{
				pp[j] = 1;
			}
		}
	}
}
int main()
{
	isprime();

	//找素数个数,并把素数都放在数组prime[15000]中
	int times = 0;
	for (int i = 2; i < maxn; i++)
	{
		if (!pp[i])
		{
			prime[times++] = i;
		}
	}

	for (int i = 0; i < times-1; i++)
	{
		int tmp = prime[i + 1] - prime[i];
		if (tmp <= 150)
			vec[tmp].push_back(prime[i + 1]);
	}

	int t, cnt=0;
	int a, b;
	scanf("%d", &t);
	while (t--)
	{
		//cin >> a >> b;
		scanf("%d%d", &a, &b);
		int abss = abs(a - b);//两个数的差一直都不变
		int maxx = a > b ? a : b;//一开始的最大
		int res = 0;//加上x后的最大
		for (int i=0;i<vec[abss].size();i++)
		{
			if (vec[abss][i] >= maxx)
			{
				res = vec[abss][i]; //找到一个能满足的最小的就行了
				break;
			}
		}
		printf("Case %d: ", ++cnt);
		//printf(res ? "%d\n" : "-1\n", res - maxx);
		if (res == 0)
			puts("-1");
		else
			//cout << res - maxx << endl;
			printf("%d\n", res - maxx);
	}

	system("pause");
	return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值