挑战程序设计竞赛 POJ 3253 贪心+霍夫曼思想+优先队列


Fence Repair
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 43729 Accepted: 14256

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer  N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make  N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

Source



注意

1.优先队列取数的时候是从大开始取,用greater改成从小开始取值,头文件functional

priority_queue<int, vector<int>, greater<int> > pque;

2.这类篱笆分割的问题可以利用哈夫曼树,每次都取最小的两个,其实就是求最小的WPL,



/*
* poj 3253
* author  : mazciwong
* creat on: 2016-1-15
*/

/*
贪心,类似于用二叉树构造霍夫曼树
每次取最小的两个加起来再加到原来那里,
利用优先队列可以把找最小的O(n) 转换成O(log n)
*/


#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <functional> //greater
#include <algorithm>
using namespace std;
typedef long long ll;
const int maxn = 20000 + 5;
int l[maxn];
int n;

void solve()
{
	ll ans = 0;

	//优先队列是从大开始取的,这样写可以从小开始取出来,利用堆数据结构
	priority_queue<int, vector<int>, greater<int> > pque;
	for (int i = 0; i < n; i++)
		pque.push(l[i]);

	//一直循环到只有一块 → 就是最开始的那块木板了
	while (pque.size() > 1)
	{
		int l1 = pque.top();
		pque.pop();
		int l2 = pque.top();
		pque.pop();

		ans += l1 + l2;
		pque.push(l1 + l2);
	}
	printf("%lld\n", ans);
}
int main()
{
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
		scanf("%d", &l[i]);
	solve();
	return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值