POJ 3253 STL priority_queue

Fence Repair
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 26845 Accepted: 8732

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needsN (1 ≤N ≤ 20,000) planks of wood, each having some integer lengthLi (1 ≤Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into theN planks (i.e., whose length is the sum of the lengthsLi). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of theN-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create theN planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

 

题意:一个长度为L的木板要被切成N块,分别为L1、L2、、、Ln,每次切断木板所需开销为此木板长度,问最小开销是多少?

 

分析:最初我认为每次只需切出最长的那块就行,但实际上每次分成的两块如果每块再继续分的话,有可能比切出最长的方法开销要小。比如5: 1、2、3、4、5这组数据,它的答案应该是33,而我最初的想法得到的答案是34。后来发现这是一个哈夫曼树问题!!!。可以利用优先队列(每次将权值最小的两块加起来再入队),最终求得答案。注意整型范围。

#include<stdio.h>
#include<queue>
using namespace std;
int main()
{
    int n, L;

    while(~scanf("%d", &n))
    {
        priority_queue<int, vector<int>, greater<int> > q;
        //由小到大排序的优先队列
        for(int i=1; i<=n; i++)
        {
            scanf("%d", &L);
            q.push(L);
        }
        long long sum = 0;
        while(q.size() > 1)
        {
            int a = q.top();
            q.pop();
            int b = q.top();
            q.pop();
            sum += a+b;
            q.push(a+b);
        }
        printf("%lld\n", sum);
    }
    return 0;
}

注意:优先队列本是由大到小排序的,所以如果反过来需要重载运算符。我从网上看到了如上的一个可以不用重载运算符就能使队列从小到大的优先队列的用法。里面最后一个 int是指入队的数据类型。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值