Have Fun with Numbers(大数相加)

Have Fun with Numbers 

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes

2469135798

题意:不超过20位的大数与自身相加,判断和是否是原数的一个全排列,是则输出Yes, 不是则输出No,最后一行输出所得和。

水题

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;

char a[50];
int b[50], c[10];

int main()
{
	gets(a);
	int len = strlen(a);
	int jin = 0, cnt = 0;
	for(int i = len - 1; i >= 0; i--)
	{
		int x = (int)a[i] - '0';
		c[x]++;
		b[cnt] = (x * 2 + jin) % 10;
		if(x * 2 + jin >= 10)
			jin = 1;
		else
			jin = 0;
		cnt++;
	}
	if(jin == 1)
	{
		b[cnt] = 1;
		cnt++;
	}
	int  i;
	for(i = 0; i < cnt; i++)
	{
		c[b[i]]--;
	}
	for(i = 0; i < 10; i++)
	{
		if(c[i] != 0)
			break;
	}
	if(i == 10)
		printf("Yes\n");
	else
		printf("No\n");
	for(i = cnt - 1; i >= 0; i--)
	{
		printf("%d", b[i]);
	}
	printf("\n");
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值