佛大菜鸟acm新篇章

10 篇文章 0 订阅

A + B Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 370602    Accepted Submission(s): 116455


Problem Description
Calculate A + B.
 

Input
Each line will contain two integers A and B. Process to end of file.
 

Output
For each case, output A + B in one line.
 

Sample Input
  
  
1 1
 

Sample Output
  
  
2 题目链接点击打开链接
#include<stdio.h>
int main()
{
int a,b;
while(~scanf("%d%d",&a,&b))//主要是这里的end of file
{
printf("%d\n",a+b);
}
return 0;
}

计算两点间的距离

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 85576    Accepted Submission(s): 32687


Problem Description
输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。
 

Input
输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。
 

Output
对于每组输入数据,输出一行,结果保留两位小数。
 

Sample Input
     
     
0 0 0 1 0 1 1 0
 

Sample Output
     
     
1.00 1.41
 
题目链接 点击打开链接
#include<stdio.h>
#include<math.h>
int main()
{
float a,b,c,d;
while(~scanf("%f%f%f%f",&a,&b,&c,&d))//注意end of file的运用
{
printf("%.2f\n",sqrt((a-c)*(a-c)+(b-d)*(b-d)));
}
return 0;
}

第三题链接 点击打开链接
第四题链接 点击打开链接

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值