[CF1067D] computer game

Computer Game

题面翻译

有n个游戏,每个游戏有收益ai,升级后的收益bi,每次成功概率pi。每秒可以玩一个游戏,如果成功则得到当前收益,并且可以升级任意某个游戏。求t秒后的期望收益的最大值。n≤1e5,t≤1e10,a<b

题目描述

Ivan plays some computer game. There are $ n $ quests in the game. Each quest can be upgraded once, this increases the reward for its completion. Each quest has $ 3 $ parameters $ a_{i} $ , $ b_{i} $ , $ p_{i} $ : reward for completing quest before upgrade, reward for completing quest after upgrade ( $ a_{i} < b_{i} $ ) and probability of successful completing the quest.

Each second Ivan can try to complete one quest and he will succeed with probability $ p_{i} $ . In case of success Ivan will get the reward and opportunity to upgrade any one quest (not necessary the one he just completed). In case of failure he gets nothing. Quests do not vanish after completing.

Ivan has $ t $ seconds. He wants to maximize expected value of his total gain after $ t $ seconds. Help him to calculate this value.

输入格式

First line contains $ 2 $ integers $ n $ ( $ 1 \le n \le 10^{5} $ ) and $ t $ ( $ 1 \le t \le 10^{10} $ ) — number of quests and total time.

Following $ n $ lines contain description of quests. Each description is $ 3 $ numbers $ a_{i} $ $ b_{i} $ $ p_{i} $ ( $ 1 \le a_{i} < b_{i} \le 10^{8} $ , $ 0 < p_{i} < 1 $ ) — reward for completing quest before upgrade, reward for completing quest after upgrade and probability of successful completing of quest. $ a_{i} $ and $ b_{i} $ are integers. All probabilities are given with at most $ 9 $ decimal places.

输出格式

Print the expected value.

Your answer will be accepted if absolute or relative error does not exceed $ 10^{-6} $ . Formally, let your answer be $ a $ , and the jury's answer be $ b $ . Your answer is considered correct if $ \frac{|a-b|}{max⁡(b, ,, 1)} \le 10^{-6} $ .

样例 #1

样例输入 #1

3 2
3 1000 0.5
1 2 0.48
3 20 0.3

样例输出 #1

252.2500000000000

样例 #2

样例输入 #2

2 2
1 1000 0.1
2 3 0.2

样例输出 #2

20.7200000000000

容易发现,当某一次游戏成功后,一定是一直选择 \(p_ib_i\) 最大的游戏玩。设 \(s=\max\limits_{i=1}^n p_ib_i\)
定义 \(dp_i\) 为还有 \(i\) 次操作时,最大的期望。
那么 \(dp_i=\max\limits_{j=1}^n(1-p_j)dp_{i-1}+p_j(a_j+(i-1)s)=dp_{i-1}+p_j((i-1)s-dp_{i-1})+a_j\)

\(dp_{i}\) 的答案时,我们发现要想办法找到这个 \(j\)。把第 \(j\) 个游戏看为平面直角坐标系上 \(p_j,p_j\times b_j\) 的一个点的话,你会发现所有可能的决策一定在这些点的凸包上。容易证明 \((i-1)s-dp_{i-1}\) 一定是单调递增的,所以有决策单调性,可以扫过去判断哪个是最优决策。复杂度 \(O(n+T)\)

然后考虑把 \(T\) 给省掉。由于很长的一段 \(dp\) 都是一样的操作,这个操作可以用矩阵快速幂加速,所以考虑上矩阵乘法。倍增结束位置(也可以推数学),然后矩阵乘法计算判断有没有超过斜率的范围,复杂度降到 \(O(nlogT)\)

注意卡精度,把斜率的除法要全部换成乘法。

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
const int N=1e5+5;
const double eps=1e-12;
struct matrix{
	double a[3][3];
	matrix operator*(const matrix&m)const{
		matrix s;
		memset(s.a,0,sizeof(s.a));
		for(int i=0;i<3;i++)
			for(int j=0;j<3;j++)
				for(int k=0;k<3;k++)
					s.a[i][k]+=a[i][j]*m.a[j][k];
		return s;
	}
	void operator=(const matrix&m){
		memcpy(a,m.a,sizeof(a));
	}
}pw[50],h,k;
struct line{	
	double k,b;
	int id;
}g[N];
int n,st[N],tp=1,a[N];
LL t,nw;
double s,p[N],dp;
int cmp1(line x,line y)
{
	if(fabs(x.k-y.k)>eps)
		return x.k<y.k;
	return x.b>y.b;
}
double sl(int x,int y)
{
	return (g[y].b-g[x].b)/(g[x].k-g[y].k);
}
int main()
{
	scanf("%d%lld",&n,&t);
	for(int i=1,b;i<=n;i++)
		scanf("%d%d%lf",a+i,&b,p+i),s=max(s,p[i]*b);
	for(int i=1;i<=n;i++)
		g[i]=(line){p[i],p[i]*a[i],i};
	sort(g+1,g+n+1,cmp1);
	st[1]=1;
	for(int i=2;i<=n;i++)
	{
		if(fabs(g[i].k-g[st[tp]].k)<=eps)
			continue;
		while(tp^1&&(g[i].b-g[st[tp]].b)*(g[st[tp-1]].k-g[st[tp]].k)<(g[st[tp]].b-g[st[tp-1]].b)*(g[st[tp]].k-g[i].k))
			--tp;
		st[++tp]=i;
	}
	pw[0].a[1][1]=1;
	pw[0].a[2][1]=1;
	pw[0].a[2][2]=1;
	h.a[0][2]=1;
	for(int i=1;i<=tp;i++)
	{
		while(i^tp&&(nw*s-h.a[0][0])*(g[st[i+1]].k-g[st[i]].k)>g[st[i]].b-g[st[i+1]].b)
			++i;
		pw[0].a[0][0]=1-p[g[st[i]].id];
		pw[0].a[1][0]=p[g[st[i]].id]*s;
		pw[0].a[2][0]=p[g[st[i]].id]*a[g[st[i]].id];
		for(int i=1;i<=40;i++)
			pw[i]=pw[i-1]*pw[i-1];
		for(int j=40;~j;--j)
		{
			if(nw+(1LL<<j)<t&&(i==tp||((nw+(1LL<<j))*s-(h*pw[j]).a[0][0])*(g[st[i+1]].k-g[st[i]].k)<=g[st[i]].b-g[st[i+1]].b))
			{
				nw+=1LL<<j;
				h=h*pw[j];
			}
		}
		h=h*pw[0],++nw;
		if(nw==t)
			break;
	}
	printf("%.6lf",h.a[0][0]);
}
  • 23
    点赞
  • 12
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
C语言是一种广泛使用的编程语言,它具有高效、灵活、可移植性强等特点,被广泛应用于操作系统、嵌入式系统、数据库、编译器等领域的开发。C语言的基本语法包括变量、数据类型、运算符、控制结构(如if语句、循环语句等)、函数、指针等。在编写C程序时,需要注意变量的声明和定义、指针的使用、内存的分配与释放等问题。C语言中常用的数据结构包括: 1. 数组:一种存储同类型数据的结构,可以进行索引访问和修改。 2. 链表:一种存储不同类型数据的结构,每个节点包含数据和指向下一个节点的指针。 3. 栈:一种后进先出(LIFO)的数据结构,可以通过压入(push)和弹出(pop)操作进行数据的存储和取出。 4. 队列:一种先进先出(FIFO)的数据结构,可以通过入队(enqueue)和出队(dequeue)操作进行数据的存储和取出。 5. 树:一种存储具有父子关系的数据结构,可以通过中序遍历、前序遍历和后序遍历等方式进行数据的访问和修改。 6. 图:一种存储具有节点和边关系的数据结构,可以通过广度优先搜索、深度优先搜索等方式进行数据的访问和修改。 这些数据结构在C语言中都有相应的实现方式,可以应用于各种不同的场景。C语言中的各种数据结构都有其优缺点,下面列举一些常见的数据结构的优缺点: 数组: 优点:访问和修改元素的速度非常快,适用于需要频繁读取和修改数据的场合。 缺点:数组的长度是固定的,不适合存储大小不固定的动态数据,另外数组在内存中是连续分配的,当数组较大时可能会导致内存碎片化。 链表: 优点:可以方便地插入和删除元素,适用于需要频繁插入和删除数据的场合。 缺点:访问和修改元素的速度相对较慢,因为需要遍历链表找到指定的节点。 栈: 优点:后进先出(LIFO)的特性使得栈在处理递归和括号匹配等问题时非常方便。 缺点:栈的空间有限,当数据量较大时可能会导致栈溢出。 队列: 优点:先进先出(FIFO)的特性使得

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值