【poj-2406-powerstring】(KMP)

Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
解析:
总结一下,如果对于next数组中的 i, 符合 i % ( i - next[i] ) == 0 && next[i] != 0 , 则说明字符串0-n-1循环,而且
循环节长度为: i - next[i]
循环次数为: i / ( i - next[i] )
如果要问为什么可以自习用几个栗子,然后啃一啃
或者看这里:
next[i]数组的含义是0-i-1个字符中前next[i]和倒数next[i]是完全相同的,
那么如果next[i] < (i-1)/2 (即如果这完全相同的前缀和后缀不重合的话)
那么有i-next[i]>(i-1)/2则i不可能有i%[i-next[i]]==0这种情况是不可能有循*环串的,*
因为如果是循环串,公共的前缀和后缀肯定是重合的
下面考虑如果重合的情况,如果重合的话,那么一定有i-next[i]就是最小的循环节长度

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char str[1000010];
int next[1000010],m;
void get_next()
{
    int j=0,i=0;
    next[i]=-1;
    j=next[i];
    while(i<m)
    {
        if(j==-1||str[i]==str[j])
        next[++i]=++j;
        else j=next[j];
    }
}
/*
总结一下,如果对于next数组中的 i, 符合 i % ( i - next[i] ) == 0 && next[i] != 0 , 则说明字符串0-n-1循环,而且

循环节长度为:   i - next[i]

循环次数为:       i / ( i - next[i] )

如果要问为什么可以自习用几个栗子,然后啃一啃

或者看这里:

next[i]数组的含义是0-i-1个字符中前next[i]和倒数next[i]是完全相同的,
那么如果next[i] < (i-1)/2 (即如果这完全相同的前缀和后缀不重合的话)
那么有i-next[i]>(i-1)/2则i不可能有i%[i-next[i]]==0这种情况是不可能有循环串的,
因为如果是循环串,公共的前缀和后缀肯定是重合的
下面考虑如果重合的情况,如果重合的话,那么一定有i-next[i]就是最小的循环节长度

*/
int main()
{
    while(~scanf("%s",str)&&strcmp(str,"."))
    {
        m=strlen(str);
        get_next();
        if(m%(m-next[m])==0)
        printf("%d\n",m/(m-next[m]));
        else printf("1\n");
    }

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值