Power Strings(KMP)

Given two strings a and b we define ab to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.

Sample Input
abcd
aaaa
ababab
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题意;计算所给字符串的最小循环节的长度。
题解;通过KMP算法得到字符串最长的相同的前后缀的长度,用字符串长度减去它,若所得值能被字符串长度整除,则存在最小循环节且该值为最小循环节的长度。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s[1100110];
int next[1100110];   //next[i]表示前面长度为i的子串中, 
int len;             //前缀和后缀相等的最大长度
void getnext(char a[])
{
    int i=0,j=-1;
    next[0]=-1;
    while(i<len)
    {
        if(j==-1||a[i]==a[j])
        {
            i++,j++;
            next[i]=j;
        }
        else
        j=next[j];
    }
}
int main()
{
    while(~scanf("%s",s))
    {
        if(s[0]=='.')
            break;
        len=strlen(s);
        getnext(s);
        int length=len-next[len];   //最小循环节长度 
        if(len%length==0)  //判断是否字符串完全由循环节组成 
        printf("%d\n",len/length);
        else
        printf("1\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值