Power Strings【KMP】

题目描述:

Given two strings a and b we define ab to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3

思路:

先求出KMP中的next数组,此问题的关键是最后的判断条件。因为next数组的含义是最大的后缀与前缀相等的长度,如果不符合条件,( n-ne[n] )就不会被n整除。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int N=1000010;

int n;
char p[N];
int ne[N];
int main()
{
    while(scanf("%s",p+1) && p[1]!='.')
    {
        int ans;
        n=strlen(p+1);
        for(int i=2,j=0;i<=n;i++)
        {
            while(j && p[i]!=p[j+1])j=ne[j];
            if(p[i]==p[j+1])j++;
            ne[i]=j;
        }
        if (n%(n-ne[n])==0) ans=n/(n - ne[n]);
        else ans = 1;
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值