sdut_java_2-2 Time类的定义

2-2 Time类的定义

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description

通过本题目的练习可以掌握类与对象的定义;

设计一个时间类Time,私有数据成员有hour()minute()second()

公有成员函数有:setHour(int)设置数据成员hour的值(采用12小时制),非法的输入默认为12setMinue(int)设置数据成员minute的值,非法输入默认为0setSecond(int)设置数据成员second的值,非法输入默认为0setTime(intintint)设置时、分、秒三个数据成员的值; showTime()显示时间对象的值。

在主函数main()中调用相应成员函数,使得时间对象的值能从键盘接收,并正确显示。

提示:时、分、秒均按2位数值形式显示 。

Input
输入 3 个整数,用一个空格间隔
Output
输出  时、分、秒的值,中间用“:”间隔
Example Input
10 11 12
Example Output
10:11:12
Hint

输入

58 23 85

输出

12:23:00

import java.text.DecimalFormat;
import java.util.Scanner;

public class Main {
	
	public static void main(String[] args) {
		
		Scanner in = new Scanner(System.in);
		while( in.hasNext() ){
			int h = in.nextInt();
			int m = in.nextInt();
			int s = in.nextInt();
			Time ti = new Time();
			ti.setTime(h, m, s);
			ti.showTime();
		}
		in.close();
	}
}

class Time {
	int h, m, s;
	
	public void setTime( int h, int m, int s ){
		if( h<0 || h>=24 )
			h = 12;
		this.h = h;
		if( m>=0 && m<=59 )
			this.m = m;
		if ( s>=0 && s<=59 )
			this.s = s;
	}
	
	public void showTime(){
		DecimalFormat x = new DecimalFormat("00");
		System.out.println(x.format(h) + ":" + x.format(m) + ":" + x.format(s));   
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值