SDUT-2669 2-2 Time类的定义

2-2 Time类的定义

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description

通过本题目的练习可以掌握类与对象的定义;

设计一个时间类Time,私有数据成员有hour()minute()second()

公有成员函数有:setHour(int)设置数据成员hour的值(采用12小时制),非法的输入默认为12setMinue(int)设置数据成员minute的值,非法输入默认为0setSecond(int)设置数据成员second的值,非法输入默认为0setTime(intintint)设置时、分、秒三个数据成员的值; showTime()显示时间对象的值。

在主函数main()中调用相应成员函数,使得时间对象的值能从键盘接收,并正确显示。

提示:时、分、秒均按2位数值形式显示 。

Input
输入 3个整数,用一个空格间隔
Output
输出 时、分、秒的值,中间用“:”间隔
Example Input
10 11 12
Example Output
10:11:12
Hint

输入

58 23 85

输出

12:23:00

#include <iostream>
using namespace std;
class time
{
private:
    int h;
    int m;
    int s;
public:
    void seth(int hh);
    void setm(int mm);
    void sets(int ss);
    void show();
};
void time::seth(int hh)
{
    if(hh>12||hh<0)
        h=12;
    else
        h=hh;
}
void time::setm(int mm)
{
    if(mm>59||mm<0)
        m=0;
    else
        m=mm;
}
void time::sets(int ss)
{
    if(ss>59||ss<0)
        s=0;
    else
        s=ss;
}
void time::show()
{
    if(h<10)
        cout<<'0'<<h<<':';
    else
        cout<<h<<':';
    if(m<10)
        cout<<'0'<<m<<':';
    else
        cout<<m<<':';
    if(s<10)
        cout<<'0'<<s<<endl;
    else
        cout<<s<<endl;
}
int main()
{
    class time a;
    int h,m,s;
    cin>>h>>m>>s;
    a.seth(h);
    a.setm(m);
    a.sets(s);
    a.show();
    return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值