[TOJ 3655] Bomb

1 篇文章 0 订阅

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

Output

For each test case, output an integer indicating the final points of the power.

Sample Input

3
1
50
500

Sample Output

0
1

15

很简单的数位统计题, 此类题目最好一律采用记忆化搜索的方法进行统计,好想又好写。

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
long long dp[100][3];
long long n;
int num[100];
long long dfs(int pos,int have,int ca)
{
    if(pos==-1) return have==2;
    if(!ca&&dp[pos][have]!=-1) return dp[pos][have];
    int v=ca?(num[pos]):9;
    long long ans=0;
    for(int i=0;i<=v;i++)
    {
        int nhave=have;
        if(have==0&&i==4)
            nhave=1;
        if(have==1&&i!=4)
            nhave=0;
        if(have==1&&i==9)
            nhave=2;
        ans+=dfs(pos-1,nhave,ca&&(i==v));
    }
    if(!ca)
    {
        return dp[pos][have]=ans;
    }
    return ans;

}
long long get(long long p)
{
    int len=0;
    while(p)
    {
        num[len++]=p%10;
        p/=10;
    }
    return dfs(len-1,0,1);
}
int main()
{
    memset(dp,-1,sizeof(dp));
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld",&n);
        printf("%lld\n",get(n));
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值