hdu3555——Bomb(数位dp)

Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

Output
For each test case, output an integer indicating the final points of the power.

Sample Input
3
1
50
500

Sample Output
0
1
15

这题跟不要62有点区别,最后的状态要判断下,相比之下复杂了点。并且不能直接算出没有49的数,当然也可能是我没想到正确的做法

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <map>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 10000000005
#define Mod 10001
using namespace std;
int dight[30];
long long dp[30][3];
long long dfs(int pos,int s,bool limit)
{
    if(pos<0)
        return s==2; //求符合条件的数与求不符合条件的区别
    if(!limit&&dp[pos][s]!=-1)
        return dp[pos][s];
    int end;
    long long ret=0;
    if(limit)
        end=dight[pos];
    else
        end=9;
    for(int d=0;d<=end;++d)
    {
        int have=s;
        if(s==1&&d==9)
            have=2; //有了49,后面就随便填了
        if(s==0&&d==4)
            have=1; //有了4,要注意后面是否会有9
        if(s==1&&d!=4&&d!=9)
            have=0; //不用注意了
        ret+=dfs(pos-1,have,limit&&d==end);
    }
    if(!limit)
        dp[pos][s]=ret;
    return ret;

}
long long solve(long long a)
{
    memset(dight,0,sizeof(dight));
    int cnt=0;
    while(a!=0)
    {
        dight[cnt++]=a%10;
        a/=10;
    }
    return dfs(cnt-1,0,1);
}
int main()
{
    memset(dp,-1,sizeof(dp));
    int t;
    scanf("%d",&t);
    long long n;
    while(t--)
    {
        scanf("%I64d",&n);
        printf("%I64d\n",solve(n));
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值