杭电 3342 Legal or Not(拓扑排序)

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6330    Accepted Submission(s): 2961


Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.
 

Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 

Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 

Sample Input
  
  
3 2 0 1 1 2 2 2 0 1 1 0 0 0
 

Sample Output
  
  
YES NO
题目大意:

a是b的师傅,通过拓扑排序的步骤,如果能正确操作完所有步骤就输出YES(一会详解,这里说的比较浅),否则输出NO。

这里a是b的师傅,b不能是a的师傅,如果b是a的师傅要输出NO(题目样例2可看出)这里b是a的师傅表示与全序关系概念相反(矛盾),就是说题意就是要找是否有这样的矛盾,如果存在就输出NO。

全序关系概念:在数学中,集合 X 上的全序关系(Total order),简称全序、又名线性序(linear order)、简单序(simple order),或(非严格)排序((non-strict) ordering),是在 X 上的反对称的、传递的和完全的任何二元关系[1] 


以上概念来自百度百科。

我们这里先解代码核心部分:

这里degree数组表示度,map表示图。

        int cont=0;
        int flag=0;
        while(1)
        {
            int v;
            int ok=1;
            for(int i=0;i<n;i++)
            {
                if(degree[i]==0){v=i;ok=0;break;}
            }
            if(ok==1){flag=1;break;}//如果ok==1表示没有度为0的点了,而且这个时候我们并没有把所有点解决掉,这个时候就表示有出现矛盾的边了。
            degree[v]=-1;
            cont++;
            if(cont==n)break;
            for(int i=0;i<n;i++)//常规去边减度操作、
            {
                if(map[v][i]==1)
                {
                    map[v][i]=-1;
                    degree[i]--;
                }
            }
        }
        if(flag==1)
        {
            printf("NO\n");
        }
        else printf("YES\n");
然后上完整AC代码:

#include<stdio.h>
#include<string.h>
using namespace std;
int map[1000][1000];
int degree[1000];
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        memset(map,0,sizeof(map));
        memset(degree,0,sizeof(degree));
        if(n==0&&m==0)break;
        for(int i=0;i<m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(map[x][y]==0)
            {
                map[x][y]=1;
                degree[y]++;
            }
        }
        int cont=0;
        int flag=0;
        while(1)
        {
            int v;
            int ok=1;
            for(int i=0;i<n;i++)
            {
                if(degree[i]==0){v=i;ok=0;break;}
            }
            if(ok==1){flag=1;break;}
            degree[v]=-1;
            cont++;
            if(cont==n)break;
            for(int i=0;i<n;i++)
            {
                if(map[v][i]==1)
                {
                    map[v][i]=-1;
                    degree[i]--;
                }
            }
        }
        if(flag==1)
        {
            printf("NO\n");
        }
        else printf("YES\n");
    }
}





















  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值