杭电OJ 5601N*M bulbs (论思维定式的口怕)


Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 715    Accepted Submission(s): 379


Problem Description
There is a number N.You should output "YES" if N is a multiple of 2, 3 or 5,otherwise output "NO".
 


Input
There are multiple test cases, no more than 1000 cases.
For each case,the line contains a integer N. (0<N<1030)
 


Output
For each test case,output the answer in a line.
 


Sample Input
  
  
2 3 5 7
 


Sample Output
  
  
YES YES YES NO



我们都知道,如果一个数都全部数字加和对3求余==0那么这个数就能整除3,但是呢,这个定理好像对素数以外的数不管用,比如整除2,13各个数字加和为4%2==0但是13%2!=0,思维定式WA了一发。可悲可悲。。。另外注意是大数就行。

#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
    char a[200];
    while(~scanf("%s",a))
    {
        __int64 sum=0;
        int n=strlen(a);
        for(int i=0;i<n;i++)
        {
            sum+=a[i]-'0';
        }
        int output=0;
        if(sum%3==0)output=1;
        if((a[n-1]-'0')%2==0||a[n-1]=='5')output=1;
        if(output==1)
        printf("YES\n");
        else printf("NO\n");
    }
}













  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值