hdoj5585Numbers



Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 271    Accepted Submission(s): 186


Problem Description
There is a number N.You should output "YES" if N is a multiple of 2, 3 or 5,otherwise output "NO".
 

Input
There are multiple test cases, no more than 1000 cases.
For each case,the line contains a integer N. (0<N<1030)
 

Output
For each test case,output the answer in a line.
 

Sample Input
      
      
2 3 5 7
 

Sample Output
      
      
YES YES YES NO
 

#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
char str[35];
int main()
{
    int i,l;
    while(scanf("%s",str)!=EOF){
        l=strlen(str);
        int sum=0;
        for(i=0;i<l;++i){
            sum+=str[i]-'0';
        }
        if(sum%3==0){
            printf("YES\n");
        }
        else if((str[l-1]-'0')%2==0||str[l-1]=='5'){
            printf("YES\n");
        }
        else {
            printf("NO\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值