HDOJ 5585 Numbers (水)

Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 52    Accepted Submission(s): 41


Problem Description
There is a number N.You should output "YES" if N is a multiple of 2, 3 or 5,otherwise output "NO".
 

Input
There are multiple test cases, no more than 1000 cases.
For each case,the line contains a integer N. (0<N<1030)
 

Output
For each test case,output the answer in a line.
 

Sample Input
  
  
2 3 5 7
 

Sample Output
  
  
YES YES YES NO
 

题意:输入一个数,判断是不是2,3,5的倍数
思路:转换为字符串形式,找出符合整除的条件:
2的倍数:末尾数字为2的倍数
3的倍数:所有位数加起来整除3
5的倍数:最后一位为5的倍数或者最后一位为0(因为n>0)


ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define fab(a) (a)>0?(a):(-a)
#define LL long long
#define MAXN 3000
#define INF 0xfffffff 
using namespace std;
char s[MAXN];
int main()
{
	int i;
    while(scanf("%s",s)!=EOF)
    {
    	int len=strlen(s);
    	int num=s[len-1]-'0';
    	int sum=0;
    	for(i=0;i<len;i++)
    	sum+=s[i]-'0';
    	if(num%2==0||sum%3==0||num%5==0||num==0)
    	printf("YES\n");
    	else
    	printf("NO\n");
	}
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值