hrbust 2024/hdu2899 Strange fuction【三分】

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5275    Accepted Submission(s): 3767


Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
  
  
2 100 200
 

Sample Output
  
  
-74.4291 -178.8534
 

因为有这样的一组数据,所以直接三分是不能实现的:


测试代码:

        for(int i=0;i<=100;i++)
        {
            double x=i;
            printf("%.3lf\n",f(x,y));
        }



因为不是单调的,所以直接二分是不行的。这里强调一下二分必须是单调的才可以直接使用~

所以这里上三分代码即可:

#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
double f(double x,double y)
{
    return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*x*x-y*x;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        double y;
        scanf("%lf",&y);
        double output=0x1f1f1f1f;
        double l=0;
        double r=100;
        double lm,rm;
        while(r-l>1e-6)
        {
            lm=(2*l+r)/3;
            rm=(l+2*r)/3;
            if(f(lm,y)>f(rm,y))l=lm;
            else r=rm;
        }
        printf("%.4lf\n",f(l,y));
    }
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值