hdu 5631 Rikka with Graph【并查集+判断一个祖先+思维】

Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 55    Accepted Submission(s): 22


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph.

Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected.

It is too difficult for Rikka. Can you help her?
 


Input
The first line contains a number T(T30) ——The number of the testcases.

For each testcase, the first line contains a number n(n100) .

Then n+1 lines follow. Each line contains two numbers u,v , which means there is an edge between u and v.
 


Output
For each testcase, print a single number.
 


Sample Input
  
  
1 3 1 2 2 3 3 1 1 3
 


Sample Output
  
  
9


这个题在比赛的时候我是这样的思路:

枚举删除1条边的情况,两条边的情况....n条边的情况,删除相当于不建、然后判断是否连通即可、然后默默想到如果是100个点,C100取30就是一个超级庞大的数据,TLE是难免不了的了,然后就发懵、到底他娘的应该怎么做才能优化呢、然后一直在卡,最后看到了官方题解,恍然大悟,最多我们也就枚举两个点,C100取2才能多大呢...

然后默默的写起来代码:

我们先上两个重要部分的代码;

void solve(int x)//删除一条边的时候
{
    init();
    for(int i=0;i<n+1;i++)
    {
        if(i!=x)
        {
            merge(u[i],v[i]);
        }
    }
    int cont=0;
    for(int i=1;i<=n;i++)//判断只有一个祖先
    {
        if(f[i]==i)
        cont++;
    }
    if(cont==1)
    output++;
}
void solve2(int x,int y)//删除两条边的时候
{
    init();
    for(int i=0;i<n+1;i++)
    {
        if(i!=x&&i!=y)
        {
            merge(u[i],v[i]);
        }
    }
    int cont=0;
    for(int i=1;i<=n;i++)//判断只有一个祖先
    {
        if(f[i]==i)
        cont++;
    }
    if(cont==1)
    output++;
}

最后上完整的AC代码:

 

#include<stdio.h>
#include<string.h>
using namespace std;
int u[121];
int v[121];
int f[121];
int n;
int output;
int find(int x)
{
    return f[x] == x ? x : (f[x] = find(f[x]));
}
void merge(int a,int b)
{
    int A,B;
    A=find(a);
    B=find(b);
    if(A!=B)
    f[B]=A;
}
void init()
{
    for(int i=0;i<=n;i++)
    {
        f[i]=i;
    }
}
void solve(int x)
{
    init();
    for(int i=0;i<n+1;i++)
    {
        if(i!=x)
        {
            merge(u[i],v[i]);
        }
    }
    int cont=0;
    for(int i=1;i<=n;i++)
    {
        if(f[i]==i)
        cont++;
    }
    if(cont==1)
    output++;
}
void solve2(int x,int y)
{
    init();
    for(int i=0;i<n+1;i++)
    {
        if(i!=x&&i!=y)
        {
            merge(u[i],v[i]);
        }
    }
    int cont=0;
    for(int i=1;i<=n;i++)
    {
        if(f[i]==i)
        cont++;
    }
    if(cont==1)
    output++;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0;i<n+1;i++)
        {
            scanf("%d%d",&u[i],&v[i]);
        }
        output=0;
        for(int i=0;i<n+1;i++)
        {
            solve(i);
        }
        for(int i=0;i<n+1;i++)
        {
            for(int j=i+1;j<n+1;j++)
            {
                solve2(i,j);
            }
        }
        printf("%d\n",output);
    }
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值