hdu 5631 Rikka with Graph(并查集)

Rikka with Graph
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them: 

Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph. 

Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected. 

It is too difficult for Rikka. Can you help her?

Input

The first line contains a number  ——The number of the testcases. 

For each testcase, the first line contains a number 

Then n+1 lines follow. Each line contains two numbers   , which means there is an edge between u and v.

Output

For each testcase, print a single number.

Sample Input

1
3
1 2
2 3
3 1
1 3

Sample Output

9
简单并查集,
给出一张 n个点 n+1 条边的无向图,你可以选择一些边(至少一条)删除。

现在勇太想知道有多少种方案使得删除之后图依然联通。采用并查集的方法进行判断是否连通。由于点和边都很少,所以就可以直接暴力。删一条边并查集一次,删两条边并查集一次。最后判断所有的点是否在一棵树上,就可以统计有多少种方法了
#include<cstdio>  
#include<algorithm>  
#include<iostream>  
using namespace std;  
int a[10000],n; 
void init()
{
	for(int i=1;i<=n;i++)  
    {a[i]=i;  
    } 
} 
int find(int x)  
{  
    if( a[x]!= x )   
    a[x] = find(a[x]);     
    return a[x];      
}  
void mange(int x,int y)  
{  
    int fx,fy;  
    fx=find(x);  
    fy=find(y);  
    if(fx!=fy)  
    a[fx]=fy;  
}  
int main()  
{  
    int m,t;  
	scanf("%d",&t);
	while(t--)  
    {scanf("%d",&n);  
    m=0; 
    int x=0,y=0,h=0;  
    int K1[1000],K2[10000];  
        for(int i=1;i<=n+1;i++)   
        scanf("%d%d",&K1[i],&K2[i]);  
        for(int i=1;i<=n+1;i++)//删去一条边
		{  init();
		for(int j=1;j<=n+1;j++)
		{if(i==j)
		continue;
		mange(K1[j],K2[j]);}
		h=0;
		for(int i=1;i<=n;i++)  
        {  
            if(a[i]==i)  
            h++;  
        } 
        if(h==1)
        m++;
		}
			for(int i=1;i<=n+1;i++)
		{   for(int j=i+1;j<=n+1;j++)//删去两条边
		{   init();	
	         for(int k=1;k<=n+1;k++)
			{if(k==i||k==j)
			continue;
			mange(K1[k],K2[k]);}
			h=0;
			for(int i=1;i<=n;i++)  
        {  
            if(a[i]==i)  
            h++;  
              
        } 
        if(h==1)
        m++;
		} }
         
        printf("%d\n",m);  
        
    }  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值