HDU 5631 Rikka with Graph

Rikka with Graph

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph.

Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected.

It is too difficult for Rikka. Can you help her?
Input
The first line contains a number T(T≤30)T(T≤30)——The number of the testcases.

For each testcase, the first line contains a number n(n≤100)n(n≤100).

Then n+1 lines follow. Each line contains two numbers u,vu,v , which means there is an edge between u and v.
Output
For each testcase, print a single number.
Sample Input
1
3
1 2
2 3
3 1
1 3
Sample Output
9

题意:现在个你一个图。有n个点,有n+1个边,问你去下一些边仍是连通的;

题解:由于仍是连通的,所以最多去掉两个边,暴力即可;

#include<stdio.h>
#include<string.h>
int road[1010];
int n;
struct node {
    int a;
    int b;
}st[110];
int find(int a)
{
    if(road[a]==a) return a;
    else
    return find(road[a]);
}
void mix(int a,int b)
{
    int x;
    int y;
    x=find(a);
    y=find(b);
    if(x!=y)
    road[x]=y;
}

 void init()
 {
        for(int i=1;i<=n;i++)
        road[i]=i;  
 }

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        init();

        scanf("%d",&n);
        int a, b;
        for(int i=1;i<=n+1;i++)
        {
            scanf("%d%d",&a,&b);
            st[i].a =a;
            st[i].b =b;
        }   
        int ans=0,s=0;
        for(int i=1;i<=n+1;i++)//一条边; 
        {
            init();
            s=0;
            for(int j=1;j<=n+1;j++)
            {
                if(j!=i)
                {
                    mix(st[j].a ,st[j].b );

                }

             } 
            for(int ll=1;ll<=n;ll++)
                if(road[ll]==ll)
                {
                    s++;
                }
                if(s==1)
                ans++;

        }
    //  printf("%d||| \n",ans);
        for(int i=1;i<=n;i++) //two ways
        {
            for(int j=i+1;j<=n+1;j++)
            {
                init();
                s=0;
                for(int k=1;k<=n+1;k++)
                {
                    if(k==i||k==j)
                    {
                        continue;
                    }
                    else
                    {
                            mix(st[k].a ,st[k].b );
                    }
                }
                for(int zz=1;zz<=n;zz++)
                if(road[zz]==zz)
                {
                    s++;
                }
                if(s==1)
                ans++;
            }
        }


        printf("%d\n",ans);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值