hdu 1240 Asteroids!【BFS】

Asteroids!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4582    Accepted Submission(s): 2951


Problem Description
You're in space.
You want to get home.
There are asteroids.
You don't want to hit them.
 

Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 5 components:

Start line - A single line, "START N", where 1 <= N <= 10.

Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

'O' - (the letter "oh") Empty space

'X' - (upper-case) Asteroid present

Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.

Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.

End line - A single line, "END"

The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

The first coordinate in a set indicates the column. Left column = 0.

The second coordinate in a set indicates the row. Top row = 0.

The third coordinate in a set indicates the slice. First slice = 0.

Both the Starting Position and the Target Position will be in empty space.

 

Output
For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.
Sample Input
START 1
O
0 0 0
0 0 0
END
START 3
XXX
XXX
XXX
OOO
OOO
OOO
XXX
XXX
XXX
0 0 1
2 2 1
END
START 5
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
XXXXX
XXXXX
XXXXX
XXXXX
XXXXX
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
0 0 0
4 4 4
END
 


Sample Output
1 0
3 4
NO ROUTE

 

题目大意:O是空地,X是小海星,主人公并不想伤害小海星,所以他不能踩着小海星向前行进,但是他还想回家,希望你编程搞定这个问题,给你一个三维立体空间的图,然后给你一个起点和一个终点 。如果有路能够从起点到终点,那么输出n和最小步数,否则输出NO ROUTE。


思路:


看到三维不要怕,只要从二维的四种走法,变成六种走法就行了,首先我们把图看成一个三维立体的图。对于一个平面内有4种走法,前后左右,对于另外两种走法就是要从一层走到另一层,那么就是上和下两种走法。


创建a【z】【x】【y】数组来存图、然后这里有一个技巧,在输入起点的时候,x和z的输入顺序换个位子即可。

创建vis【z】【x】【y】来判重。

AC代码:

#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
struct zuobiao
{
    int x,y,z,output;
}now,nex;
char start[15];
char a[25][25][25];
int vis[25][25][25];
int fx[6]={0,0,1,-1,0,0};
int fy[6]={1,-1,0,0,0,0};
int fz[6]={0,0,0,0,1,-1};
int n,ex,ey,ez;
void bfs(int x,int y,int z)
{

    memset(vis,0,sizeof(0));
    vis[x][y][z]=1;
    now.x=x;now.y=y;now.z=z;now.output=0;
    queue<zuobiao >s;
    s.push(now);
    while(!s.empty())
    {
        now=s.front();
        //printf("%d %d %d\n",now.x,now.y,now.z);
        if(now.x==ex&&now.y==ey&&now.z==ez)
        {
            printf("%d %d\n",n,now.output);
            return ;
        }
        s.pop();
        for(int i=0;i<6;i++)
        {
            nex.x=now.x+fx[i];
            nex.y=now.y+fy[i];
            nex.z=now.z+fz[i];
            if(nex.x>=0&&nex.x<n&&nex.y>=0&&nex.y<n&&nex.z>=0&&nex.z<n&&vis[nex.x][nex.y][nex.z]==0&&a[nex.x][nex.y][nex.z]!='X')
            {
                nex.output=now.output+1;
                s.push(nex);
                vis[nex.x][nex.y][nex.z]=1;
            }
        }
    }
    printf("NO ROUTE\n");
}
int main()
{
    while(~scanf("%s%d",start,&n))
    {
        int sx,sy,sz;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                scanf("%s",a[i][j]);
            }
        }
        scanf("%d%d%d%d%d%d",&sz,&sy,&sx,&ez,&ey,&ex);
        scanf("%s",start);
        bfs(sx,sy,sz);
    }
}









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值