POJ 3723 Conscription【最大生成树】

Conscription
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10608 Accepted: 3737

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2
5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781
5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223


题目大意:

有n个妹纸,有m个汉纸,如果妹纸x和汉纸y之间有关系,辣么我们在雇佣汉纸的是时候就能节省w辣么多的钱,问怎样能够用最小的雇佣费用来雇佣n+m个人,每个人的固定雇佣费需要10000元。


思路:对于每个人,我们都对其编号,男生的0号我们标记为n号,男生的1号我们标记为n+1号,给定这么些个关系,我们只需要贪心的入边使得这些边权值最大,并且能够构成一颗最大生成树辣么这棵最大生成树的值辣么就是节省下来的最大值。


AC代码:

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
struct path
{
    int x,y,w;
}a[121212];
int f[121212];
int cmp(path a,path b)
{
    return a.w>b.w;
}
int find(int a)
{
    int r=a;
    while(f[r]!=r)
    r=f[r];
    int i=a;
    int j;
    while(i!=r)
    {
        j=f[i];
        f[i]=r;
        i=j;
    }
    return r;
}
void merge(int a,int b)
{
    int A,B;
    A=find(a);
    B=find(b);
    if(A!=B)
    f[B]=A;
}
int main()
{
    //printf("%d\n",100000-6831-6592-3063-2104-781-4583-4975);
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m,k;
        scanf("%d%d%d",&n,&m,&k);
        for(int i=0;i<n+m;i++)
        {
            f[i]=i;
        }
        for(int i=0;i<k;i++)
        {
            scanf("%d%d%d",&a[i].x,&a[i].y,&a[i].w);
            a[i].y+=n;
        }
        int output=0;
        sort(a,a+k,cmp);
        for(int i=0;i<k;i++)
        {
            if(find(a[i].x)!=find(a[i].y))
            {
                output+=a[i].w;
                merge(a[i].x,a[i].y);
            }
        }
        printf("%d\n",(m+n)*10000-output);
    }
}









评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值