POJ 3522 Slim Span【枚举+克鲁斯卡尔求最小生成树】


Slim Span

Time Limit: 5000MS

 

Memory Limit: 65536K

Total Submissions: 7365

 

Accepted: 3909

Description

Given an undirected weighted graph G, you should find one of spanning trees specified as follows.

The graph G is an ordered pair (VE), where V is a set of vertices {v1v2, …, vn} and E is a set of undirected edges {e1e2, …, em}. Each edge e ∈ E has its weight w(e).

A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n − 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n − 1 edges of T.


Figure 5: A graph G and the weights of the edges

For example, a graph G in Figure 5(a) has four vertices {v1v2v3v4} and five undirected edges {e1e2e3e4e5}. The weights of the edges are w(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).


Figure 6: Examples of the spanning trees of G

There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees TbTc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input

The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.

n

m

 

a1

b1

w1

 

 

am

bm

wm

Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and 0 ≤ m ≤ n(n − 1)/2. ak andbk (k = 1, …, m) are positive integers less than or equal to n, which represent the two vertices vak and vbk connected by the kth edge ekwk is a positive integer less than or equal to 10000, which indicates the weight ofek. You can assume that the graph G = (VE) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

Output

For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, −1 should be printed. An output should not contain extra characters.

Sample Input

4 5

1 2 3

1 3 5

1 4 6

2 4 6

3 4 7

4 6

1 2 10

1 3 100

1 4 90

2 3 20

2 4 80

3 4 40

2 1

1 2 1

3 0

3 1

1 2 1

3 3

1 2 2

2 3 5

1 3 6

5 10

1 2 110

1 3 120

1 4 130

1 5 120

2 3 110

2 4 120

2 5 130

3 4 120

3 5 110

4 5 120

5 10

1 2 9384

1 3 887

1 4 2778

1 5 6916

2 3 7794

2 4 8336

2 5 5387

3 4 493

3 5 6650

4 5 1422

5 8

1 2 1

2 3 100

3 4 100

4 5 100

1 5 50

2 5 50

3 5 50

4 1 150

0 0

Sample Output

1

20

0

-1

-1

1

0

1686

50

 

题目大意:给你n个点,m条边,求一颗生成树,使得其最大权值边-最小权值边的权值最小。


分析题目:求生成树,使得最大权值边-最小权值边的权值尽可能小,我们不难想到使用克鲁斯卡尔贪心求最小生成树算法,因为贪心的求能够使得最大权值边-最小权值边尽可能的小,但是因为并不是最小生成树就一定是那棵目标生成树,所以我们这里采用枚举的方法来解决,点不多, 还给了5000ms。当然可以使用枚举的方法来解决这个问题啦~。

AC代码:


#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
struct path
{
    int x,y,w;
} a[100000];
int f[10000];
int n,m;
int output;
int cmp(path a,path b)
{
    return a.w<b.w;
}
int find(int a)
{
    int r=a;
    while(f[r]!=r)
    r=f[r];
    int i=a;
    int j;
    while(i!=r)
    {
        j=f[i];
        f[i]=r;
        i=j;
    }
    return r;
}
void merge(int a,int b)
{
    int A,B;
    A=find(a);
    B=find(b);
    if(A!=B)
    f[B]=A;
}
void init()
{
    for(int i=1; i<=n; i++)
    {
        f[i]=i;
    }
}
void solve(int x)
{
    int cont=0;
    int minn=0x1f1f1f1f;
    int maxn=-0x1f1f1f1f;
    init();
    for(int i=x; i<m; i++)
    {
        if(find(a[i].x)!=find(a[i].y))
        {
            minn=min(a[i].w,minn);
            maxn=max(a[i].w,maxn);
            merge(a[i].x,a[i].y);
            cont++;
        }
    }
    if(cont==n-1)
    {
       // printf("%d\n",maxn-minn);
        output=min(output,maxn-minn);
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n+m==0)break;
        output=0x1f1f1f1f;
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d",&a[i].x,&a[i].y,&a[i].w);
        }
        sort(a,a+m,cmp);
        for(int i=0; i<m; i++)
        {
            if(m-i<n-1)break;
            solve(i);
        }
       // printf("%d\n",output);
        if(output!=0x1f1f1f1f)
        printf("%d\n",output);
        else printf("-1\n");
    }
}









评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值