uva 1359 poj 3522 Slim Span(最小生成树)

                     uva 1359 poj 3522 Slim Span



Description

Given an undirected weighted graph G, you should find one of spanning trees specified as follows.

The graph G is an ordered pair (V, E), where V is a set of vertices {v1,v2, …, vn} and E is a set of undirected edges {e1,e2, …, em}. Each edge eE has its weightw(e).

A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices withn − 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among then − 1 edges of T.


Figure 5: A graph G and the weights of the edges

For example, a graph G in Figure 5(a) has four vertices {v1,v2, v3, v4} and five undirected edges {e1,e2, e3, e4, e5}. The weights of the edges arew(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).


Figure 6: Examples of the spanning trees of G

There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning treeTa in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the treeTa is 4. The slimnesses of spanning trees Tb,Tc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input

The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.

nm 
a1b1w1
  
ambmwm

Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ≤n ≤ 100 and 0 ≤ mn(n − 1)/2. ak andbk (k = 1, …, m) are positive integers less than or equal ton, which represent the two vertices vak andvbk connected by the kth edge ek.wk is a positive integer less than or equal to 10000, which indicates the weight ofek. You can assume that the graph G = (V, E) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

Output

For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, −1 should be printed. An output should not contain extra characters.

Sample Input

4 5
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6
1 2 10
1 3 100
1 4 90
2 3 20
2 4 80
3 4 40
2 1
1 2 1
3 0
3 1
1 2 1
3 3
1 2 2
2 3 5
1 3 6
5 10
1 2 110
1 3 120
1 4 130
1 5 120
2 3 110
2 4 120
2 5 130
3 4 120
3 5 110
4 5 120
5 10
1 2 9384
1 3 887
1 4 2778
1 5 6916
2 3 7794
2 4 8336
2 5 5387
3 4 493
3 5 6650
4 5 1422
5 8
1 2 1
2 3 100
3 4 100
4 5 100
1 5 50
2 5 50
3 5 50
4 1 150
0 0

Sample Output

1
20
0
-1
-1
1
0
1686
50


题目大意:给出一个n个结点的无向图,找一棵苗条度(最大边减去最小边)最小的生成树。图中不含重边和自环。

解题思路:先判断在图中能不能找到树,也就是边的数量是否大于点的数量减一,如果找不到树,直接输出-1。然后可以进行m - n + 1次kruskal,每进行一次,记录当前苗条度,维护ans,并排除当前生成树上的最小边。进行kruskal的时候要注意判断剩下的树还是否可以组成树。


#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
using namespace std;

typedef long long ll;
const int N = 105;
const int M = N * (N - 1) / 2;
const int INF = 0x3f3f3f3f;
int n, m;
int f[N];

struct Node{
    int x, y, len;
}q[M];

int find(int x) {
	return f[x] == x ? x : f[x] = find(f[x]);
}

void init() {
	for (int i = 0; i <= n; i++) f[i] = i;
}

int cmp(Node a, Node b) {
	return a.len < b.len;
}

void input() {
	for (int i = 0; i < m; i++) {
		scanf("%d %d %d", &q[i].x, &q[i].y, &q[i].len);
	}
    sort(q, q + m, cmp);
}

int kruskal(int s) {
	int cnt = 0, Max;
    for (int i = s; i < m; i++) {
        int x = find(q[i].x), y = find(q[i].y);
        if (x != y) {
            f[x] = y;
			cnt++;
			if (cnt == n - 1) Max = q[i].len;
        }
    }
	if (cnt != n - 1) return INF;
	return Max - q[s].len;
}

void solve() {
	int ans = INF;
	for (int i = 0; i <= m - n + 1; i++) {
		init();
		int temp = ans;
		ans = min(ans, kruskal(i));		
	}
	if (ans == INF) printf("-1\n");
	else printf("%d\n", ans);
}

int main() {
	while (scanf("%d %d", &n, &m) == 2) {
		if (!n && !m) break;
		if (m < n - 1) {
			int a, b, c;
			for (int i = 0; i < m; i++) scanf("%d %d %d", &a, &b, &c);
			printf("-1\n");
			continue;
		}
		input();
		solve();
	}
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值