POJ 2236 Wireless Network【并查集】

Wireless Network

Time Limit: 10000MS

 

Memory Limit: 65536K

Total Submissions: 21833

 

Accepted: 9171

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1

0 1

0 2

0 3

0 4

O 1

O 2

O 4

S 1 4

O 3

S 1 4

Sample Output

FAIL

SUCCESS

Source

POJ Monthly,HQM


题目大意:因为地震,电脑都不好使了,需要一台一台的修复,两个电脑之间能连接的条件是两个点之间的距离小于等于d就可以。

然后给你n个点,和一个限制约束条件d,然后接着n行表示n个点的坐标,然后输入一堆操作,处理到文件结束(EOF),对于两个操作:

1、O x 表示修复第x台电脑。

2、S x y 表示询问第x台电脑和第y台电脑是否连接起来了。


思路:给了我们10000ms,明显就是让我们暴力的。一开始还害怕暴力会超时,看到10000ms就放心了。对于每个O x操作,遍历一遍从1到n,看看这台电脑和第x台电脑能否连接起来,如果能连接起来,那就连接起来。对于每个S询问,直接find即可。


AC代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
int vis[5000];
int x[5000];
int y[5000];
int f[5000];
double dis(int a,int b,int c,int d)
{
    return sqrt((a-c)*(a-c)+(b-d)*(b-d));
}
int find(int a)
{
    int r=a;
    while(f[r]!=r)
    r=f[r];
    int i=a;
    int j;
    while(i!=r)
    {
        j=f[i];
        f[i]=r;
        i=j;
    }
    return r;
}
void merge(int a,int b)
{
    int A,B;
    A=find(a);
    B=find(b);
    if(A!=B)
    f[B]=A;
}
int main()
{
    memset(vis,0,sizeof(vis));
    int n,d;
    scanf("%d%d",&n,&d);
    for(int i=1;i<=n;i++)
    {
        scanf("%d%d",&x[i],&y[i]);
        f[i]=i;
    }
    char s[50];
    while(~scanf("%s",s))
    {
        if(s[0]=='O')
        {
            int k;
            scanf("%d",&k);
            vis[k]=1;
            for(int i=1;i<=n;i++)
            {
                if(i==k)continue;
                if(vis[i]==0)continue;
                if(dis(x[i],y[i],x[k],y[k])<=d)
                {
                    merge(i,k);
                }
            }
        }
        else
        {
            int u,v;
            scanf("%d%d",&u,&v);
            if(find(u)==find(v))
            {
                printf("SUCCESS\n");
            }
            else printf("FAIL\n");
        }
    }
}








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值