hdu 3631 Shortest Path【Floyd】

Shortest Path

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4888    Accepted Submission(s): 1188

Problem Description

When YY was a boy and LMY was a girl, they trained for NOI (National Olympiad in Informatics) in GD team. One day, GD team’s coach, Prof. GUO asked them to solve the following shortest-path problem.
There is a weighted directed multigraph G. And there are following two operations for the weighted directed multigraph:
(1) Mark a vertex in the graph.
(2) Find the shortest-path between two vertices only through marked vertices.
For it was the first time that LMY faced such a problem, she was very nervous. At this moment, YY decided to help LMY to analyze the shortest-path problem. With the help of YY, LMY solved the problem at once, admiring YY very much. Since then, when LMY meets problems, she always calls YY to analyze the problems for her. Of course, YY is very glad to help LMY. Finally, it is known to us all, YY and LMY become programming lovers.
Could you also solve the shortest-path problem?

 

 

Input

The input consists of multiple test cases. For each test case, the first line contains three integers N, M and Q, where N is the number of vertices in the given graph, N≤300; M is the number of arcs, M≤100000; and Q is the number of operations, Q ≤100000. All vertices are number as 0, 1, 2, … , N - 1, respectively. Initially all vertices are unmarked. Each of the next M lines describes an arc by three integers (x, y, c): initial vertex (x), terminal vertex (y), and the weight of the arc (c). (c > 0) Then each of the next Q lines describes an operation, where operation “0 x” represents that vertex x is marked, and operation “1 x y” finds the length of shortest-path between x and y only through marked vertices. There is a blank line between two consecutive test cases.
End of input is indicated by a line containing N = M = Q = 0.

Output

Start each test case with "Case #:" on a single line, where # is the case number starting from 1.
For operation “0 x”, if vertex x has been marked, output “ERROR! At point x”.
For operation “1 x y”, if vertex x or vertex y isn’t marked, output “ERROR! At path x to y”; if y isn’t reachable from x through marked vertices, output “No such path”; otherwise output the length of the shortest-path. The format is showed as sample output.
There is a blank line between two consecutive test cases.

Sample Input

5 10 10

1 2 6335

0 4 5725

3 3 6963

4 0 8146

1 2 9962

1 0 1943

2 1 2392

4 2 154

2 2 7422

1 3 9896

0 1

0 3

0 2

0 4

0 4

0 1

1 3 3

1 1 1

0 3

0 4

0 0 0

Sample Output

Case 1:

ERROR! At point 4

ERROR! At point 1

0

0

ERROR! At point 3

ERROR! At point 4

 

 题目大意:有n个点,m条边,q个询问,对于询问有两种:

1、0 x表示对点x的选取与否进行查询,如果没有选取过,那么选取,如果选取过了,输出ERROR! AT point X

2、1 x y 对于两点间x y的查询,如果x,y有一方没有被选取过,那么输出ERROR! At path x to y,如果两个点都被选取过,而其间现在还没有一条路相通,输出No such path。如果有路径相通,输出此时最短路径。


思路:

对于Floyd步骤的考察,我们正常的Floyd,是每次选取两个点,通过另外一个点进行松弛动态规划的过程。这个另外一个点,就是最外层的for,内层两个for就是每次枚举选取的两个点,而这个题,要求每次选取一个点进行Floyd,其实就是设定这个点作为刚刚叙述过程的“另外一个点”,每一次输入都进行一次模拟即可。


AC代码:


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int map[305][305];
int vis[305];
int n,m,q;
void init()
{
    for(int i=0;i<n;i++)
    {
        map[i][i]=0;
        for(int j=0;j<n;j++)
        {
            if(i==j)continue;
            map[i][j]=0x3f3f3f3f;
        }
    }
    for(int i=0;i<n;i++)map[i][i]=0;
    memset(vis,0,sizeof(vis));
}
int main()
{
    int kase=0;
    while(~scanf("%d%d%d",&n,&m,&q))
    {
        if(n==0&&m==0&&q==0)break;
        init();
        for(int i=0;i<m;i++)
        {
            int x,y,w;
            scanf("%d%d%d",&x,&y,&w);
            map[x][y]=min(map[x][y],w);
        }
        if(kase!=0)printf("\n");
        printf("Case %d:\n",++kase);
        while(q--)
        {
            int op;
            scanf("%d",&op);
            if(op==0)
            {
                int x;
                scanf("%d",&x);
                if(vis[x]==1)
                {
                    printf("ERROR! At point %d\n",x);
                    continue;
                }
                vis[x]=1;
                for(int j=0;j<n;j++)
                {
                    for(int k=0;k<n;k++)
                    {
                        if(map[j][x]==0x3f3f3f3f||map[x][k]==0x3f3f3f3f)continue;
                        map[j][k]=min(map[j][k],map[j][x]+map[x][k]);
                    }
                }
            }
            if(op==1)
            {
                int x,y;
                scanf("%d%d",&x,&y);
                if(vis[x]==0||vis[y]==0)
                {
                    printf("ERROR! At path %d to %d\n",x,y);
                }
                else
                {
                    if(map[x][y]==0x3f3f3f3f)
                    {
                        printf("No such path\n");
                    }
                    else printf("%d\n",map[x][y]);
                }
            }
        }
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值