hdu 2888 Check Corners【RMQ】


Check Corners

Time Limit: 2000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2718    Accepted Submission(s): 952


Problem Description
Paul draw a big m*n matrix A last month, whose entries Ai,j are all integer numbers ( 1 <= i <= m, 1 <= j <= n ). Now he selects some sub-matrices, hoping to find the maximum number. Then he finds that there may be more than one maximum number, he also wants to know the number of them. But soon he find that it is too complex, so he changes his mind, he just want to know whether there is a maximum at the four corners of the sub-matrix, he calls this “Check corners”. It’s a boring job when selecting too many sub-matrices, so he asks you for help. (For the “Check corners” part: If the sub-matrix has only one row or column just check the two endpoints. If the sub-matrix has only one entry just output “yes”.)
 

Input
There are multiple test cases. 

For each test case, the first line contains two integers m, n (1 <= m, n <= 300), which is the size of the row and column of the matrix, respectively. The next m lines with n integers each gives the elements of the matrix which fit in non-negative 32-bit integer. 

The next line contains a single integer Q (1 <= Q <= 1,000,000), the number of queries. The next Q lines give one query on each line, with four integers r1, c1, r2, c2 (1 <= r1 <= r2 <= m, 1 <= c1 <= c2 <= n), which are the indices of the upper-left corner and lower-right corner of the sub-matrix in question. 
 

Output
For each test case, print Q lines with two numbers on each line, the required maximum integer and the result of the “Check corners” using “yes” or “no”. Separate the two parts with a single space.
 

Sample Input
  
  
4 4 4 4 10 7 2 13 9 11 5 7 8 20 13 20 8 2 4 1 1 4 4 1 1 3 3 1 3 3 4 1 1 1 1
 

Sample Output
  
  
20 no 13 no 20 yes 4 yes
 

Source
 

题目大意:给你一个n*m的矩阵,让你输出询问中的矩阵中的最大值,并且判断一下这个最大值是否在四个角落上。


思路:

二维RMQ+简单判断即可


Ac代码:

#include<stdio.h>
#include<iostream>
#include<math.h>
#include<string.h>
using namespace std;
int a[305][305];
int maxn[305][305][10];
int n,q,m;
void ST()
{
    int len=floor(log10(double(m))/log10(double(2)));
    for(int k=1;k<=n;k++)
    {
        for(int j=1;j<=len;j++)
        {
            for(int i=1;i<=(m+1)-(1<<j);i++)
            {
                maxn[k][i][j]=max(maxn[k][i][j-1],maxn[k][i+(1<<(j-1))][j-1]);
            }
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(maxn,0,sizeof(maxn));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                scanf("%d",&a[i][j]);
                maxn[i][j][0]=a[i][j];
            }
        }
        ST();
        scanf("%d",&q);
        while(q--)
        {
            int x,y,x2,y2;
            int ans=0;
            scanf("%d%d%d%d",&x,&y,&x2,&y2);
             int len= floor(log10(double(y2-y+1))/log10(double(2)));
            //printf("%d\n",len);
            for(int i=x;i<=x2;i++)
            {

                ans=max(ans,maxn[i][y][len]);
                ans=max(ans,maxn[i][y2-(1<<len)+1][len]);
            }
            printf("%d",ans);
            if(ans==a[x][y]||ans==a[x2][y2]||ans==a[x][y2]||ans==a[x2][y])
            {
                printf(" yes\n");
            }
            else printf(" no\n");
        }
    }
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值