Hdu 1796 How many integers can you find【二进制枚举容斥原理入门】

How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8886    Accepted Submission(s): 2647


Problem Description
  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 

Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
 

Output
  For each case, output the number.
 

Sample Input
  
  
12 2 2 3
 

Sample Output
  
  
7

题目大意:

统计能够整除m个数中任意一个数的数的个数,要求这些数要小于n。


思路:


基础容斥原理:




观察到数据范围比较小,那么我们直接暴力二进制枚举即可。


Ac代码:

#include<stdio.h>
#include<string.h>
using namespace std;
int n,m,k;
int a[15];
int gcd(int x,int y)
{
    if(x%y==0)return y;
    else return gcd(y,x%y);
}
int lcm(int x,int y)
{
    return x/gcd(x,y)*y;
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        m=0;
        for(int i=0;i<k;i++)
        {
            int x;scanf("%d",&x);
            if(x>0)a[m++]=x;
        }
        int ans=0;
        for(int i=1;i<(1<<m);i++)
        {
            int lc=-1;
            int cnt=0;
            for(int j=0;j<m;j++)
            {
                if((i&(1<<j))>0)
                {
                    cnt++;
                    if(lc==-1)lc=a[j];
                    else lc=lcm(a[j],lc);
                }
            }
            if(lc==-1)continue;
            int val=(n-1)/lc;
            if(cnt%2==1)ans+=val;
            else ans-=val;
        }
        printf("%d\n",ans);
    }
}








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值