HDU 1010 Tempter of the Bone (DFS+剪枝)

本文介绍了一款迷宫逃脱游戏中的算法实现,利用深度优先搜索(DFS)结合奇偶剪枝技巧帮助游戏角色找到在限定时间内逃出迷宫的方法。文章详细解释了算法流程与关键代码,包括如何通过奇偶剪枝判断是否能成功到达出口。
摘要由CSDN通过智能技术生成

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze. 

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him. 

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following: 

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or 
'.': an empty block. 

The input is terminated with three 0's. This test case is not to be processed. 

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise. 

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0

Sample Output

NO
YES

 

听同学讲了之后才明白的,这里面有一个通过奇偶剪枝的一个过程,大概过程以及原理如下:

     到达当前点的时候,让总的时间减去当前已经消耗的时间,再减去从该点出发直线到达终点所需的时间(理论上的,假设没有墙体等障碍),如果所剩余时间为奇数,则不可能到达终点,可以理解为如果实际路线如果偏离理论上的的最短路线,实际路线仍旧是以最短路线为基础的,相当于他离开了最短路线,但是最终还是要返回到最短路线,来回一趟,所需时间,必定是偶数。

还有一个难理解的点就是DFS的回溯,因为DFS是一次性向下搜索的,并且是单个路线,一个人走,和BFS的多条路同时进行是不一样的,所以当他遇到不能再走的情况时,就要回到上一个点,所以一定要标记回来。

#include <iostream>
#include <string.h>
#include <cmath>
using namespace std;
int n,m,t;
int x2,y2;//last
int vis[10][10];
char map[10][10];
int flag;
int d[4][2]={1,0,-1,0,0,1,0,-1};
void dfs(int x,int y,int et)
{
	if(x<0 || x>=n || y<0 || y>=m || vis[x][y]==1 || map[x][y]=='X')
	return ;
	if(flag==1)
	return ;
	int temp=t-et-abs(x-x2)-abs(y-y2);
	if(temp<0 || temp&1)//奇偶剪枝 
	return ;
	if(x==x2 && y==y2 && et==t)
	{
		flag=1;
		return ;	
	}
	for(int i=0;i<4;i++)  
	{
		vis[x][y]=1;//先标记为已访问 
		dfs(x+d[i][0],y+d[i][1],et+1);
		vis[x][y]=0;	//为回溯,标记为未访问 
	}	
}
int main()
{
	while(cin>>n>>m>>t && n!=0 || m!=0 || t!=0)
	{
		int i,j,x,y;
		flag=0;
		for(i=0;i<n;i++)
		for(j=0;j<m;j++)
		{
			cin>>map[i][j];
			if(map[i][j]=='D')
			{
				x2=i;
				y2=j;
			}
			if(map[i][j]=='S')
			{
				x=i;
				y=j;
			}
		}
		dfs(x,y,0);
		if(flag)
		cout<<"YES"<<endl;
		else
		cout<<"NO"<<endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值