hdu1517 A Multiplication Game

67 篇文章 1 订阅

A Multiplication Game

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3013 Accepted Submission(s): 1732


Problem Description
Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.

Input
Each line of input contains one integer number n.

Output
For each line of input output one line either

Stan wins.

or

Ollie wins.

assuming that both of them play perfectly.

Sample Input
  
  
162 17 34012226

Sample Output
  
  
Stan wins. Ollie wins. Stan wins.
这题 我们想,如果,n不断的除成了一个小于9的数m,那么第一个人只需要第一步变成m,以后,不论第二个人乘k,他只要乘18/k,那么,最后一定是第一个人赢,相反,也是一个道理,所以,这题,可以很容易的得出结论!
#include <iostream>
#include <stdio.h>
using namespace std;

int main()
{
    double  n;
    while(scanf("%lf",&n)!=EOF){
        while(n>18){
            n=n/18;
        }
        if(n>9)printf("Ollie wins.\n");
        else printf("Stan wins.\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值