hdu 1208 Pascal's Travels

17 篇文章 0 订阅
An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one square dictates how large a step away from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is a dead end which prevents any further progress.


Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed.

Input

The input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number of rows in this board. This is followed by n rows of data. Each row contains n single digits, 0-9, with no spaces between them.

Output

The output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 2^63 paths for any board.

Sample Input

4
2331
1213
1231
3110
4
3332
1213
1232
2120
5
11101
01111
11111
11101
11101
-1

Sample Output

3
0
7

【题意】

给你一张图,图里有一些数字,表示能从该点能且仅能向下或者向右走对应数字的步数,问你从图中左上角走到右下角的可行方案数。

【分析】

逆向建图,然后直接逆推求和答案就行了。

【代码】

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<cmath>
#include<map>
#include<time.h>
#include<bits/stdc++.h>
using namespace std;
int mat[50][50];
long long ans[2500];
vector<int>go[2500];
int main()
{
//    freopen("in.txt","r",stdin);
    int n,m;
    while(scanf("%d",&n),n!=-1)
    {
        memset(ans,0,sizeof(ans));
        for(int i = 0;i<2500;i++)
            go[i].clear();
        m = n;
        for(int i = 0; i<n; i++) for(int j = 0; j<m; j++)
            {
                scanf("%1d",&mat[i][j]);
                if(mat[i][j])
                {
                    int now = i+mat[i][j];
                    if(now<n)
                        go[now*m+j].push_back(i*m+j);
                    now = j+mat[i][j];
                    if(now<m)
                        go[i*m+now].push_back(i*m+j);
                }
            }
        ans[n*m-1] = 1;
        for(int i = n-1; i>=0; i--)
            for(int j = m-1; j>=0; j--)
            {
                int now = i*m+j;
                int si = go[now].size();
                for(int k = 0; k<si; k++)
                {
                    int nex = go[now][k];
                    ans[nex]+=ans[now];
                }
            }
        printf("%lld\n",ans[0]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zuhiul

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值