Light Bulb-------三分查找

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

 

Sample Output

1.000
0.750
4.000
本来此题直接推出了公式,直接找到了最值点的。
但是看到网上好多用三分法做的,就复习了下三分法,因为是凸的,所以用三分。
 
 
公式法:
复制代码
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
using namespace std;

int main()
{
   // freopen("in.txt","r",stdin);
   // freopen("out.txt","w",stdout);
    int T;
    double H,h,D;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lf%lf%lf",&H,&h,&D);
        double temp=sqrt((H-h)*D);
        double temp2=(H-h)*D/H;
        if(temp>=D)printf("%.3lf\n",h);
        else if(temp<temp2)printf("%.3lf\n",h*D/H);
        else
        {
            double ans=D+H-temp-(H-h)*D/temp;
            printf("%.3lf\n",ans);
        }
    }
    return 0;
}
复制代码

 

 

三分法:

复制代码
 



#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const double eps=1e-8;
double H,h,D,ans;
double Cal(double l){
	return l+D*(h-l)/(H-l);
}
int main(){ 
	int t;
	scanf("%d",&t);
	while(t--){
		scanf("%lf%lf%lf",&H,&h,&D);
		double left=0,right=h,mid,midmid;
		while(right-left>=eps){
			mid=(left+right)/2;
			midmid=(mid+right)/2;
			if(Cal(mid)>Cal(midmid))
			right=midmid;
			else 
			left=mid;
		}
		printf("%.3lf\n",Cal(left));
	}
	return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值