Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.
输入
The first line of the input contains an integer T (T <= 100), indicating the number of cases.
Each test case contains three real numbers H, h and D in one line.H is the height of the light bulb whileh is the height of mildleopard.D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, andH -h >= 10-2.
输出
For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..
样例输入
3 2 1 0.5 2 0.5 3 4 3 4
样例输出
1.000 0.750 4.000
这道题直接最长影子可能在地上,可能在墙上,可能部分在地上,部分在墙上;
通过分析不难得到各个可能对应的最长影子
令A为人头 灯 以及竖直线的角度
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <stack>
#include <string.h>
#include <vector>
#include <queue>
#include <cmath>
#include <iomanip>
using namespace std;
int main()
{
int t;
cin>>t;double H,h,D;
while(t--)
{
scanf("%lf%lf%lf",&H,&h,&D);
double tem=D/(H-h);
double tt=D/H;
//投影在墙上时;影子长度为:H+D-(D/tanA+(H-h)tanA);
//经求导,tanA^2>tem时,函数单减但前提是A要大于D/H才能投影在墙上,所以取最小值都>tem的话,影子的长度只会随着A的增大而单减;
//所以
if(tem<t*t)
{
//投影在地上是最长的;
printf("%.3lf\n",h*tt);
}
else if(tem<=1)
{//对应在墙上的情况
printf("%.3lf\n",h);
}
else
{
//对应部分在墙上部分在地上的情况
printf("%.3lf\n",H+D-(H-h)*sqrt(tem)-D/sqrt(tem));
}
}
}