How far away ?

Description

There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.
 

Input

First line is a single integer T(T<=10), indicating the number of test cases. 
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n. 
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.
 

Output

For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.
 

Sample Input

    
    
2 3 2 1 2 10 3 1 15 1 2 2 3 2 2 1 2 100 1 2 2 1
 

Sample Output

    
    
10 25 100 100

 

题目大意:一个村子里有n个房子,这n个房子用n-1条路连接起来,接下了有m次询问,每次询问两个房子a,b之间的距离是多少。

从某点到某点有且只有一条路

#include<stdio.h>  
#include<vector>  
#include<string.h>  
using namespace std;  
struct haha  
{  
    int pos;  
    int val;  
}temp,q;  
vector<struct haha>a[44444];  
int n,m,flag,e,vis[444444];  
void DFS(int s,int ans)  
{  
    //printf("s=%d\n",s);  
    int size,i;  
    if(vis[s]) return ;  
    if(flag) return ;  
    if(s==e) {printf("%d\n",ans);flag=1;return;}  
     if(a[s].empty())  return ;  
     else  
     {  
    vis[s]=1;  
     size=a[s].size();  
     for(i=0;i<size;i++)  
        DFS(a[s][i].pos,ans+a[s][i].val);  
     vis[s]=0;  
     }  
}  
int main()  
{  
    int cas;  
    scanf("%d",&cas);  
    while(cas--)  
    {  
        int i,j,x,y,z;  
        scanf("%d %d",&n,&m);  
        for(i=0;i<n-1;i++)  
        {  
                scanf("%d %d %d",&x,&y,&z);  
                q.pos=y;q.val=z;  
                a[x].push_back(q);  
                q.pos=x;q.val=z;  
                a[y].push_back(q);  
        }  
        for(j=0;j<m;j++)  
        {  
            memset(vis,0,sizeof(vis));  
            flag=0;  
            int s;  
            scanf("%d %d",&s,&e);  
            DFS(s,0);  
        }  
        for(i=0;i<n;i++)  
        {  
            a[i].clear();  
        }  
    }  
      return 0;  
}  

lca模板:

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <time.h>
#include <math.h>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-8
#define pi acos(-1.0)
typedef long long ll;
const int maxn=50010;
int head[maxn],tol,dis[maxn],fa[maxn][20],dep[maxn];
struct node{
  int next,to,val;
}edge[5*maxn];
void addedge(int u,int v,int w){
  edge[tol].to=v;
  edge[tol].next=head[u];
  edge[tol].val=w;
  head[u]=tol++;
}
void bfs(int root){
  queue<int> q;
  fa[root][0]=root;dep[root]=0;dis[root]=0;
  q.push(root);
  while(!q.empty()){
    int u=q.front();q.pop();
    for(int i=1;i<20;i++)fa[u][i]=fa[fa[u][i-1]][i-1];
    for(int i=head[u];i!=-1;i=edge[i].next){
      int v=edge[i].to;if(v==fa[u][0])continue;
      dep[v]=dep[u]+1;dis[v]=dis[u]+edge[i].val;fa[v][0]=u;
      q.push(v);
    }
  }
}
int lca(int x,int y){
  if(dep[x]<dep[y])swap(x,y);
  for(int i=0;i<20;i++)if((dep[x]-dep[y])&(1<<i))x=fa[x][i];
  if(x==y)return x;
  for(int i=0;i<20;i++)if(fa[x][i]!=fa[y][i])x=fa[x][i],y=fa[y][i];
  return fa[x][0];
}
int main()
{
  //freopen("data.in","r",stdin);
  //freopen("data.out","w",stdout);
  int T,n,m;
   scanf("%d",&T);
   while(T--){
     scanf("%d%d",&n,&m);
     memset(head,-1,sizeof(head));tol=0;
     for(int i=1;i<n;i++){
       int u,v,w;
       scanf("%d%d%d",&u,&v,&w);
       addedge(u,v,w);
       addedge(v,u,w);
     }
     bfs(1);
     while(m--){
       int u,v;
       scanf("%d%d",&u,&v);
       printf("%d\n",dis[u]+dis[v]-2*dis[lca(u,v)]);
     }
   }
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值