hdu 4951 Multiplication table 哈希水过

Multiplication table

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 373    Accepted Submission(s): 182


Problem Description
Teacher Mai has a multiplication table in base p.

For example, the following is a multiplication table in base 4:

* 0 1 2 3
0 00 00 00 00
1 00 01 02 03
2 00 02 10 12
3 00 03 12 21


But a naughty kid maps numbers 0..p-1 into another permutation and shuffle the multiplication table.

For example Teacher Mai only can see:

1*1=11 1*3=11 1*2=11 1*0=11
3*1=11 3*3=13 3*2=12 3*0=10
2*1=11 2*3=12 2*2=31 2*0=32
0*1=11 0*3=10 0*2=32 0*0=23


Teacher Mai wants you to recover the multiplication table. Output the permutation number 0..p-1 mapped into.

It's guaranteed the solution is unique.
 

Input
There are multiple test cases, terminated by a line "0".

For each test case, the first line contains one integer p(2<=p<=500).

In following p lines, each line contains 2*p integers. The (2*j+1)-th number x and (2*j+2)-th number y in the i-th line indicates equation i*j=xy in the shuffled multiplication table.

Warning: Large IO!
 

Output
For each case, output one line.

First output "Case #k:", where k is the case number counting from 1. The following are p integers, indicating the permutation number 0..p-1 mapped into.
 

Sample Input
  
  
4 2 3 1 1 3 2 1 0 1 1 1 1 1 1 1 1 3 2 1 1 3 1 1 2 1 0 1 1 1 2 1 3 0
 

Sample Output
  
  
Case #1: 1 3 2 0
 

Source
 
看到这种题目实在是没有想法,然后想一下数据弱的时候能不能直接哈希。
刚开始直接统计每个数在第一位的个数和在第二位的个数,然后存在map里面,发现wa了,看来有数据冲突。。
然后每一行记录一下每个数在第一位的个数和在第二位的个数,然后排序之后再哈希,map保存。。竟然能够过。。

/***********************************************\
 |Author: Messyidea
 |Created Time: 2014-8-15 9:44:03
 |File Name: 4591.cpp
 |Description: 
\***********************************************/
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <string>
#include <cstring>
#include <algorithm>
#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#define L(rt) (rt<<1)
#define R(rt) (rt<<1|1)
#define mset(l,n) memset(l,n,sizeof(l))
#define rep(i,n) for(int i=0;i<n;++i)
#define maxx(a) memset(a, 0x3f, sizeof(a))
#define zero(a) memset(a, 0, sizeof(a))
#define srep(i,n) for(int i = 1;i <= n;i ++)
#define MP make_pair
const int inf=0x3f3f3f3f ;
const double eps=1e-8 ;
const double pi=acos (-1.0);
typedef long long ll;

using namespace std;
int ma[505][505];
int mb[505][505];
int p,n,u,v,m;
unsigned long long int hash1,hash2;
map <pair<unsigned long long int,unsigned long long int>,int> mm;
const unsigned long long int B1 = 9973,B2 = 100000007;
int main() {
	//freopen("input.txt","r",stdin); 
    int cas = 1;
    while(~scanf("%d",&p)){
        if(p == 0) break;
        memset(ma,0,sizeof(ma));
        memset(mb,0,sizeof(mb));
        rep(i,p){
            rep(j,p){
                scanf("%d%d",&u,&v);
                ma[i][u]++;
                mb[i][v]++;
            }
        }
        for(int i=0;i<p;++i){
            sort(ma[i],ma[i]+p);
            sort(mb[i],mb[i]+p);
            hash1 = 1;
            hash2 = 1;
            for(int j=0;j<p;++j){
                hash1 = hash1 * B1 + ma[i][j];       
                hash2 = hash2 * B2 + mb[i][j];
            }
            mm[MP(hash1,hash2)] = i;
        }
        memset(ma,0,sizeof(ma));
        memset(mb,0,sizeof(mb));
        rep(i,p){
            rep(j,p){
                int tt = i*j;
                ma[i][tt/p]++;
                mb[i][tt%p]++;
            }
        }
        printf("Case #%d:",cas ++);
        for(int i=0;i<p;++i){
            sort(ma[i],ma[i]+p);
            sort(mb[i],mb[i]+p);
            hash1 = 1;
            hash2 = 1;
            for(int j=0;j<p;++j){
                hash1 = hash1 * B1 + ma[i][j];       
                hash2 = hash2 * B2 + mb[i][j];
            }
            printf(" %d",mm[MP(hash1,hash2)]);
        }
        puts("");

    }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值