HDU 4763 Theme Section(kmp)

Time Limit:1000MS Memory Limit:32768KB

Description
It’s time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a ‘theme section’. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of ‘EAEBE’, where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters ‘a’ - ‘z’.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?

Input
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.

Output
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.

Sample Input
5
xy
abc
aaa
aaaaba
aaxoaaaaa

Sample Output
0
0
1
1
2

题意: 给你一个字符串,找到一个在原字符串的前,中,后都有出现的最长子串。

思路: 很明显是kmp中的next数组的一个应用,先对原字符串求一遍next数组,然后得到最后一个字母和前缀匹配的最长的长度,但是,这个长度不能超过原字符串的三分之一,所以这个最长的长度ans = min( next[len] , len/3 ),然后再到中间找到一个在ans范围内的最长的一个长度,而中间的这个范围就是ans*2~len-ans,如果从 f [ ans ] 就开始找的话,可能会出现和前缀重合的情况,所以要从ans*2开始找起。

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<vector>
#include<string>
#include<queue>
#include<map>
#include<stack>
#include<set>
#define ll long long
#define maxn 1000010
const int mod=1e4+7;
using namespace std;
char s[maxn];
int f[maxn];
int n;
void getnext(char *a)
{
    memset(f,0,sizeof(f));
    int len=strlen(a);
    int i=0;
    int j=-1;
    f[0]=-1;
    while(i<len)
    {
        if(j==-1||a[i]==a[j])
        {
            i++;
            j++;
            f[i]=j;
        }
        else  j=f[j];
    }
}
int main()
{
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s",s);
        int len=strlen(s);

        getnext(s);

        int ans=min(f[len],len/3);

        int cnt=0;
        for(int i=ans*2-1;i<=len-ans;i++)  cnt=cnt>f[i]?cnt:f[i];  //注意范围,范围没找对还WA了一发

        ans=min(ans,cnt);

        printf("%d\n",ans);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值