poj__3145(配套总结本)

Harmony Forever
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 5834 Accepted: 1414

Description

We believe that every inhabitant of this universe eventually will find a way to live together in harmony and peace; that trust, patience, kindness and loyalty will exist between every living being of this earth; people will find a way to appreciate and cooperate with each other instead of continuous bickering, arguing and fighting. Harmony — the stage of society so many people dream of and yet it seems so far away from now…

Fortunately, the method of unlocking the key to true Harmony is just discovered by a group of philosophers. It is recorded on a strange meteorite which has just hit the earth. You need to decipher the true meaning behind those seemingly random symbols… More precisely, you are to write a program which will support the following two kinds of operation on an initially empty set S:

  1. B X: Add number X to set S. The Kth command in the form of B X always happens at time K, and number X does not belong to set S before this operation.
  2. A Y : Of all the numbers in set S currently, find the one which has the minimum remainder when divided by Y. In case a tie occurs, you should choose the one which appeared latest in the input. Report the time when this element is inserted.

It is said that if the answer can be given in the minimum possible time, true Harmony can be achieved by human races. You task is to write a program to help us.

Input

There are multiple test cases in the input file. Each test case starts with one integer T where 1 ≤ T ≤ 40000. The following T lines each describe an operation, either in the form of “B X” or “A Y ” where 1 ≤ X ≤ 500 000, 1 ≤ Y ≤ 1 000 000.

T = 0 indicates the end of input file and should not be processed by your program.

Output

Print the result of each test case in the format as indicated in the sample output. For every line in the form of “A Y”, you should output one number, the requested number, on a new line; output -1 if no such number can be found. Separate the results of two successive inputs with one single blank line.

Sample Input

5
B 1
A 5
B 10
A 5
A 40
2
B 1
A 2
0

Sample Output

Case 1:
1
2
1

Case 2:
1

Source

Shanghai 2006

 
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

#define LL long long
#define pb push_back
#define Set(a, v) memset(a, v, sizeof(a))
#define For(i, a, b) for(int i = (a); i <= (int)(b); i++)
#define Forr(i, a, b) for(int i = (a); i >= (int)(b); i--)

#define MAXT (40000+5)
#define MAXN (500000+5)
#define INF 0x3f3f3f3f

bool read(int &x){
	char ch = getchar();
	while(ch < '0' || ch > '9') ch = getchar();
	x = 0;
	while(ch >= '0' && ch <= '9'){
		x = x*10+ch-'0';
		ch = getchar();
	}
	return true;
}

int ql, qr;
int id[MAXN];

struct Seg_tree{
	int minv[MAXN*4];

	void init(){
		Set(minv, INF); Set(id, -1);
	}

	void insert(int o, int L, int R, int v){
		if(L == R){
			minv[o] = v; return;
		}

		int lc = o<<1, rc = o<<1|1;
		int mid = (L+R)>>1;

		if(minv[o] > v) minv[o] = v;
		if(v <= mid) insert(lc, L, mid, v);
		else insert(rc, mid+1, R, v);	
	}

	int query(int o, int L, int R){
	        if(minv[o] == INF) return INF;
		if(ql <= L && qr >= R) return minv[o];

		int lc = o<<1, rc = o<<1|1;
		int mid = (L+R)>>1;
		
		int ret = INF;
		if(ql <= mid) ret = min(ret, query(lc, L, mid));
		if(qr > mid) ret = min(ret, query(rc, mid+1, R));
		return ret;
	}
}ST;

char op[5];
int nn, num[MAXT];

int main(){
	int n, T = 0, N = 500000;
	while(read(n) && n){
		ST.init(); nn = 0;
		if(T) printf("\n");
		printf("Case %d:\n", ++T);

		int x, minv, now, ans, L, R, tot = 0;
		For(ca, 1, n){
			scanf("%s", op); read(x);
			if(op[0] == 'B') ST.insert(1, 0, N, x), num[++nn] = x, id[x] = ++tot;
			else{
				if(x <= 5000){
					minv = INF, ans = -1;
					Forr(j, nn, 1){
						if(minv > (num[j]%x)) minv = num[j]%x, ans = j;
						if(!minv) break;
					}
					printf("%d\n", ans);
				}else{
				    minv = INF, ans = -1, L = 0;
					while(L <= N){
						R = L+x-1;
						if(R > N) R = N;

						ql = L; qr = R;
						now = ST.query(1, 0, N);
                        if(now < INF && minv > (now%x)) minv = now%x, ans = id[now];
						else if(now < INF && minv == (now%x)) minv = now%x, ans = max(ans, id[now]);
						L = R+1;
					}
					printf("%d\n", ans);
			    }
			}
		}		
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值